Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67683 - [opera] fix compatibility with widevine plugin from chromium-wivevine package

Attached to Project: Community Packages
Opened by redfish (redfish) - Sunday, 23 August 2020, 02:33 GMT
Last edited by Ike Devolder (BlackEagle) - Sunday, 20 September 2020, 08:45 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ike Devolder (BlackEagle)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Unlike Chromium > 81, Opera does not ship with a plugin library for viewing Widevine media content (widely-used DRM). Opera just fails to play some media, and it is difficult to troubleshoot. Luckily, a small change to the opera PKGBUILD would be enough to make user experience nearly "working out-of-the-box." Widevine can be installed by the user from chromium-widevine package on AUR. But, a config file in opera needs an update: a potential path to widevine library needs to be added to the list. Would you mind adding somewhere in package() a command that would do the following:

In the list of paths in: /usr/lib/opera/resources/widevine_config.json
append "/usr/lib/chromium/WidevineCdm" to the list

This should be harmless, since it's a list of paths that are searched -- non-existent paths are just skipped.

Also, ideally chromium-widevine package would be added as optional dependency of opera package, but it's currently only on AUR, so it would have to be pulled into community for this to happen.

Steps to reproduce:
0. Install Opera and navigate to: https://bitmovin.com/demos/drm
1. On a fresh Opera install, shows 'No DRM': widevine is not working, so DRM media from other websites (Netflix, Spotify, etc) is unplayable.
2. Install chromium-widevine package from AUR
3. Append the path to the config file as detailed above (the point of this Bug Report is to eliminate this step for the user.)
4. Demo website should now show 'widewine'
This task depends upon

Closed by  Ike Devolder (BlackEagle)
Sunday, 20 September 2020, 08:45 GMT
Reason for closing:  Fixed
Additional comments about closing:  added in 71.0.3770.148-2

Loading...