Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67675 - [nvidia-dkms] nvidia-450.66 does not build on kernel 5.7.12-arch1-1

Attached to Project: Arch Linux
Opened by G3ro (G3ro) - Saturday, 22 August 2020, 16:36 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 22 August 2020, 17:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

#Description:
"Plugin ./scripts/gcc-plugins/structleak_plugin.so could not be initialized"
Note: Thats my translation.

#Additional info:
* nvidia-dkms: 450.66-1
* log (last part):
"
CC [M] /var/lib/dkms/nvidia/450.66/build/nvidia/nv-frontend.o
CC [M] /var/lib/dkms/nvidia/450.66/build/nvidia/nv.o
CC [M] /var/lib/dkms/nvidia/450.66/build/nvidia/nv-acpi.o
CC [M] /var/lib/dkms/nvidia/450.66/build/nvidia/nv-pci.o
cc1: Fehler: incompatible gcc/plugin versions
cc1: Fehler: Plugin ./scripts/gcc-plugins/structleak_plugin.so kann nicht initialisiert werden
cc1: Fehler: incompatible gcc/plugin versions
cc1: Fehler: Plugin ./scripts/gcc-plugins/structleak_plugin.so kann nicht initialisiert werden
make[2]: *** [scripts/Makefile.build:267: /var/lib/dkms/nvidia/450.66/build/nvidia/nv-frontend.o] Fehler 1
make[2]: *** Es wird auf noch nicht beendete Prozesse gewartet....
make[2]: *** [scripts/Makefile.build:267: /var/lib/dkms/nvidia/450.66/build/nvidia/nv.o] Fehler 1
cc1: Fehler: incompatible gcc/plugin versions
cc1: Fehler: Plugin ./scripts/gcc-plugins/structleak_plugin.so kann nicht initialisiert werden
make[2]: *** [scripts/Makefile.build:267: /var/lib/dkms/nvidia/450.66/build/nvidia/nv-acpi.o] Fehler 1
cc1: Fehler: incompatible gcc/plugin versions
cc1: Fehler: Plugin ./scripts/gcc-plugins/structleak_plugin.so kann nicht initialisiert werden
make[2]: *** [scripts/Makefile.build:267: /var/lib/dkms/nvidia/450.66/build/nvidia/nv-pci.o] Fehler 1
make[1]: *** [Makefile:1732: /var/lib/dkms/nvidia/450.66/build] Fehler 2
make[1]: Verzeichnis „/usr/lib/modules/5.7.12-arch1-1/build“ wird verlassen
make: *** [Makefile:81: modules] Fehler 2
"


#Steps to reproduce:
Install nvidia-dkms update.

#Additional comment:
I marked it as high because wiki reads:
> High - The main functionality of the application does not work

which I interpret as given, so don't be mad at me ;).

This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 22 August 2020, 17:38 GMT
Reason for closing:  Not a bug
Additional comments about closing:  partial updates are not supported

Loading...