Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67668 - [akonadi] server does not start after MariaDB upgrade to v10.5.5

Attached to Project: Arch Linux
Opened by physkets (physkets) - Saturday, 22 August 2020, 06:18 GMT
Last edited by Antonio Rojas (arojas) - Friday, 28 August 2020, 16:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

After MariaDB was updated to version 10.5.5, the Akonadi server no longer starts.

Additional info:
* package version(s)
akonadi: 20.08.0-1
mariadb: 10.5.5-2
* link to upstream bug report, if any
https://bugs.kde.org/show_bug.cgi?id=425606

Steps to reproduce:

Update to the indicated version of mariadb, and the server does not start automatically. Attempting to start it manually gives the following output:

org.kde.pim.akonadictl: Starting Akonadi Server...
QSocketNotifier: Can only be used with threads started with QThread
org.kde.pim.akonadictl: done.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
org.kde.pim.akonadiserver: Starting up the Akonadi Server...
org.kde.pim.akonadiserver: database server stopped unexpectedly
org.kde.pim.akonadiserver: Database process exited unexpectedly during initial connection!
org.kde.pim.akonadiserver: executable: "/usr/bin/mysqld"
org.kde.pim.akonadiserver: arguments: ("--defaults-file=/home/user/.local/share/akonadi/mysql.conf", "--datadir=/home/user/.local/share/akonadi/db_data/", "--socket=/run/user/1000/akonadi/mysql.socket", "--pid-file=/run/user/1000/akonadi/mysql.pid")
org.kde.pim.akonadiserver: stdout: ""
org.kde.pim.akonadiserver: stderr: "2020-08-22 11:39:12 0 [Note] /usr/bin/mysqld (mysqld 10.5.5-MariaDB) starting as process 3957 ...\n"
org.kde.pim.akonadiserver: exit code: 1
org.kde.pim.akonadiserver: process error: "Unknown error"
org.kde.pim.akonadiserver: Shutting down AkonadiServer...
org.kde.pim.akonadicontrol: Application '/usr/bin/akonadiserver' exited normally...
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 28 August 2020, 16:09 GMT
Reason for closing:  None
Additional comments about closing:  See comments
Comment by Antonio Rojas (arojas) - Thursday, 27 August 2020, 18:53 GMT Comment by physkets (physkets) - Friday, 28 August 2020, 07:04 GMT
When I try that, this is what I get:

Version check failed. Got the following error when calling the 'mysql' command line client
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/run/mysqld/mysqld.sock' (2)
FATAL ERROR: Upgrade failed

Also, after downgrading, I'm able to run KOrganizer, but all my calendar data is gone. This might be because I attmepted to follow the upgrade instructions in:
https://wiki.archlinux.org/index.php/MariaDB

This is a horrible bug since it results in data loss.
Comment by Antonio Rojas (arojas) - Friday, 28 August 2020, 07:20 GMT
Oh, the command in the reddit post is wrong. It should be 'mariadb-upgrade -S /run/user/1000/akonadi/mysql.socket' (note the missing -S). Please try it.
Comment by Robert (Loser137) - Friday, 28 August 2020, 16:02 GMT
The steps solved the problem for me.

Loading...