Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67661 - [gitlab-runner] ARM is listed but ARM64 is not

Attached to Project: Community Packages
Opened by Maciej Wójcik (w8jcik) - Friday, 21 August 2020, 22:44 GMT
Last edited by Jelle van der Waa (jelly) - Friday, 21 August 2020, 22:47 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello, the package has ARM architecture listed, but not ARM64.

GitLab offers package for ARM64 as well. Would it be possible to add it?

I know Arch project is not officially supporting ARM, but your package is actually built and running on ARM, you can search for it here https://archlinuxarm.org/packages

I am successfully building this package on Raspberry Pi 3/4 with following script, which basically changes most occurences of `arm` to `arm64`

```
git clone --branch packages/gitlab-runner --depth 1 https://github.com/archlinux/svntogit-community.git gitlab-runner
cd gitlab-runner/repos/community-x86_64
sed -i "s/('x86_64')/('x86_64' 'aarch64')/" PKGBUILD
sed -i s/-arm/-arm64/g PKGBUILD
makepkg --skipinteg
```

Script produces `gitlab-runner-*-aarch64.pkg.tar.xz` package and it works.

If ARM64 would be added, users of Raspberry Pi 3/4 would avoid building it every update :) And it makes a difference for them, because for example Raspberry Pi 3 doesn't have enough memory to do it. (swap is needed, which is not a good idea for this device)

When the package is installed, it works fine on these devices and it is very useful.
This task depends upon

Closed by  Jelle van der Waa (jelly)
Friday, 21 August 2020, 22:47 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Ask the ALARM guys for AARCH64 support.
Comment by Jelle van der Waa (jelly) - Friday, 21 August 2020, 22:47 GMT
If you want to build something on ARM you just use makepkg -A so it ignores arch=() and we don't have to change anything at all.

Loading...