Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67632 - [virtualbox] linux 5.8 patch causes kernel oops with Win10 machines using Bridged Adapters

Attached to Project: Community Packages
Opened by Dexter Gerig (Fullmetal5) - Wednesday, 19 August 2020, 02:29 GMT
Last edited by Christian Hesse (eworm) - Monday, 07 September 2020, 21:28 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
This Linux 5.8 patch introduced in rel 4 cause a kernel oops and VM lockup when booting Windows 10 machines that use a bridged network adapter.
Problem exists with the patch on both 5.8.1 and 5.7.12 kernels. Removing the patch fixes the problem but obviously virtualbox doesn't work on 5.8 kernels without it.
Tested with and without Oracle extension pack just to make sure and it indeed doesn't affect the issue.

Additional info:
core/linux 5.8.1.arch1-1
community/virtualbox 6.1.12-4
community/virtualbox-ext-vnc 6.1.12-4
community/virtualbox-guest-iso 6.1.12-1
community/virtualbox-host-dkms 6.1.12-4
community/virtualbox-sdk 6.1.12-4
aur/virtualbox-ext-oracle 6.1.13.139853-1

Win10_2004_English_x64.iso sha256sum a9efd2329ed805a6a58e0e0101f9b22ad4031e80e2c663c571cd004db26d2f31

Motherboard: MSI MS-7850/H97 PC Mate(MS-7850), BIOS V5.9 02/16/2016
CPU: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
Network adapater: 05:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe Wireless Network Adapter (rev 01)


Steps to reproduce:
Using Windows 10 ISO (Win10_2004_English_x64.iso) create a machine, leave all the defaults when creating.
In settings->Network->Attached to: set to Bridged Adapter
Boot machine, attach ISO, proceed through Windows 10 installation, doesn't matter which Windows edition is selected.
After files finish copying Windows will reboot and after the reboot while the white circles are spinning at the bottom the bug will occur and the VM will lockup.

Attached is dmesg, I can't find any matching bug reports in the virtualbox bug tracker so I assume it's some problem with the combination of cherry picked patches that Arch applies.
This task depends upon

Closed by  Christian Hesse (eworm)
Monday, 07 September 2020, 21:28 GMT
Reason for closing:  Fixed
Additional comments about closing:  virtualbox 6.1.14-1
Comment by lirdale (lirdale) - Wednesday, 02 September 2020, 18:23 GMT
Hello. I have a similar or the same issue. After starting VM with Windows 10, my system freezes completely due to kernel crash, I guess (5.8.5-arch1-1). How did you get the dmesg log? Kdump?
Comment by Adrian (adriaticc) - Thursday, 03 September 2020, 05:55 GMT
Do you continue to experience the kernel oops when running linux 5.8 and this test build of VirtualBox 6.1.13?

https://www.virtualbox.org/download/testcase/VirtualBox-6.1.13-140124-Linux_amd64.run

The installer places an uninstall script at /opt/VirtualBox/uninstall.sh if you want to just install it without first building a package.
Comment by Dexter Gerig (Fullmetal5) - Thursday, 03 September 2020, 06:07 GMT
I don't experience the bug anymore with the testcase version you linked.

Loading...