Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67627 - [emacs] emacsclient 27.1-2 fails to run

Attached to Project: Arch Linux
Opened by Eric W. Bates (ericx) - Tuesday, 18 August 2020, 12:54 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 18 August 2020, 15:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Jürgen Hötzel (juergen)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:
Something is wrong with the variable space containing the socket-name in emacsclient.
The default value for the string: /run/user/[uid]/emacs/server results in the error:

# emacsclient -c -n
emacsclient: socket-name /run/user/1000/emacs/server... too long
[Exit 1 ]

Attempting to shorten the socket-name does not help:

# emacsclient -c -n --socket /tmp/e
emacsclient: socket-name /tmp/e... too long
[Exit 1 ]


Additional info:
* emacs version 27.1-2

Steps to reproduce:
run:
export ALTERNATE_EDITOR=''
emacsclient -c -n
This task depends upon

Comment by Pedro F. «pancho» Horrillo (pancho) - Friday, 21 August 2020, 04:29 GMT
Hi, Eric.

I have tried to reproduce this, but following your instructions does indeed work for me without issues.

I wonder if you have been bitten by this change¹:

*** When run by root, emacsclient no longer connects to non-root sockets.
(Instead you can use Tramp methods to run root commands in a non-root Emacs.)

The reported error by your `emacsclient` does not match, though :-/

Just to clarify: are you running `emacsclient` as root, but with an environment that points to the user with uid 1000?
If so, could you perhaps try `sudo -i` to make the environment match root's before running `emacsclient`?

Hope that it helps, fellow emacser.

[1]: https://www.gnu.org/savannah-checkouts/gnu/emacs/news/NEWS.27.1 > emacsclient
Comment by Pedro F. «pancho» Horrillo (pancho) - Friday, 21 August 2020, 04:57 GMT
Ah, I forgot to mention that I run the emacsclient as root, with no config (no ~/.emacs.d or ~/.config/emacs).
Comment by Eric W. Bates (ericx) - Sunday, 23 August 2020, 23:25 GMT
You are correct!
Thank you.
Comment by Pedro F. «pancho» Horrillo (pancho) - Monday, 24 August 2020, 03:39 GMT
Excelent! Glad to be of service!
Comment by Pedro F. «pancho» Horrillo (pancho) - Saturday, 12 September 2020, 19:11 GMT
Hi, Eric.

Do you consider this issue solved? If so, I would suggest that you request its closure.

Thanks!
Comment by Pedro F. «pancho» Horrillo (pancho) - Thursday, 27 January 2022, 12:55 GMT
I think this one can be closed.

Loading...