Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67614 - [linux] include configurations required by Anbox in the official kernel?

Attached to Project: Arch Linux
Opened by YuutaW (YuutaW) - Sunday, 16 August 2020, 22:57 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 17 August 2020, 00:29 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
According to Arch Wiki, since kernel 5.7.0, Anbox requires the following kernel configurations:

CONFIG_ASHMEM=y
CONFIG_ANDROID=y
CONFIG_ANDROID_BINDER_IPC=y
CONFIG_ANDROID_BINDERFS=y
CONFIG_ANDROID_BINDER_DEVICES="binder,hwbinder,vndbinder"

The wiki tells me to rebuild the kernel, but it is not an efficient way for further maintenance. Thus, I think it is a good idea to have these configurations in the official kernel build. Thanks.

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 17 August 2020, 00:29 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#64778
Comment by loqs (loqs) - Sunday, 16 August 2020, 23:09 GMT

Loading...