Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67587 - [archweb] "Download From Mirror" broken in Firefox, download doesn't start

Attached to Project: Arch Linux
Opened by Ronan (ronjouch) - Saturday, 15 August 2020, 15:07 GMT
Last edited by Jelle van der Waa (jelly) - Friday, 21 August 2020, 23:34 GMT
Task Type Bug Report
Category Web Sites
Status Closed
Assigned To Jelle van der Waa (jelly)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The "Download From Mirror" link in a package page doesn't work in Firefox: download doesn't start.
The same link in the same package works under Chromium, download *does* start.
Reproducibility for me on my machine: 100%.


Additional info:
* Firefox Nightly 81.0a1-20200815093117.
* Fresh new Firefox profile with zero user configuration and zero addons, all defaults
* This is a regression (either in the website, or in Firefox) that must have happened during spring/summer 2020; I remember successfully using the feature in Firefox a few months ago.
* Disabling all Firefox Tracking protection doesn't help.


Steps to reproduce:
1. Launch Firefox
2. Navigate to https://www.archlinux.org/packages/core/x86_64/linux/
3. Click "Download From Mirror"


Expected: download starts.


Actual: download does not start. DevTools shows a HTTP 200 OK, but with an incorrect size of a few bytes. See attached screencast.
This task depends upon

Closed by  Jelle van der Waa (jelly)
Friday, 21 August 2020, 23:34 GMT
Reason for closing:  Fixed
Comment by Jelle van der Waa (jelly) - Sunday, 16 August 2020, 14:17 GMT
Most likely the mirror does not have the package yet. It's not a firefox issue at all btw.
Comment by Ronan (ronjouch) - Sunday, 16 August 2020, 14:27 GMT
> Most likely your mirror does not have the package yet.

@jelly what do you mean by "my" mirror? I haven't picked a mirror, I just want to download the package from whichever mirror has it. Shouldn't archweb pick a mirror that has the package?

Also, admitting your hypothesis, let's take another package, right? For example, https://www.archlinux.org/packages/community/x86_64/fish/ hasn't moved since May 2020, I should be able to download it. I'm not, download fails similarly.

> It's not a firefox issue at all btw.

@jelly how do you explain what I'm describing, then? See the screencast, which shows Chromium (right) vs. Firefox (left). Firefox *always* fails to download, Chromium *always* succeeds. Can you download the package through Firefox?
Comment by Robert CegliƄski (codicodi) - Sunday, 16 August 2020, 15:42 GMT
I can reproduce the issue with FF Nightly, but not with stable or developer edition. So it's probably a bug in nightly. BTW if I put the URL [1] to the address bar myself, the download starts fine in nightly too.

[1] https://www.archlinux.org/packages/community/x86_64/fish/download/
Comment by Jelle van der Waa (jelly) - Sunday, 16 August 2020, 23:11 GMT
It seems like the issue might be Firefox nightly now disallows downloading / autoloading a link from https to http, but I'll have to edit the code and check if this is the case.
Comment by Ronan (ronjouch) - Monday, 17 August 2020, 03:37 GMT
> It seems like the issue might be Firefox nightly now disallows downloading / autoloading a link from https to http, but I'll have to edit the code and check if this is the case.

Thanks for the followup.

Before this comment I had created a bug in Mozilla's Webcompat project, https://github.com/webcompat/web-bugs/issues/56727 . If your hypothesis is correct and it's new intended behavior that should be taken care of in Archweb, I'll follow up by closing the Webcompat issue.
Comment by Jelle van der Waa (jelly) - Monday, 17 August 2020, 15:01 GMT
The issue should be fixed now, as a new version of the website has been deployed.
Comment by Ronan (ronjouch) - Monday, 17 August 2020, 15:06 GMT
@jelly fix confirmed, thanks!

The webcompat bug I filed at https://github.com/webcompat/web-bugs/issues/56727 got activity. Can you summarize what was the problem in Archweb? Who was the culprit?
Comment by Ronan (ronjouch) - Monday, 17 August 2020, 18:54 GMT
All good and clear given https://github.com/webcompat/web-bugs/issues/56727#issuecomment-675051640 .

Thanks for the fast turnaround, @jelly!
Comment by Ronan (ronjouch) - Friday, 21 August 2020, 11:40 GMT
Seems broken again as of today Thursday August 20
Comment by Jelle van der Waa (jelly) - Friday, 21 August 2020, 23:34 GMT
Should be fixed again.

Loading...