Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67570 - [virtualbox] patch for kernel 5.8 breaks virtualbox for lts-kernel 5.4

Attached to Project: Community Packages
Opened by Hartmut Malzahn (hwm) - Thursday, 13 August 2020, 08:11 GMT
Last edited by Christian Hesse (eworm) - Monday, 07 September 2020, 21:29 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

after upgrading to virtualbox* 6.1.12-4, starting a virtual machine immediately crashes (see attached logfile). Downgrade to 6.1.12-3 fixes this. I'm running the lts kernel with dkms-generated virtualbox modules

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Closed by  Christian Hesse (eworm)
Monday, 07 September 2020, 21:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  virtualbox 6.1.14-1
Comment by Jez Cope (jezcope) - Thursday, 13 August 2020, 08:55 GMT
I can confirm I had the same problem on the various 5.7 kernels I have installed: linux 5.7.12.arch1-1, linux-zen 5.7.12.zen1-1 (and linux-ck 5.7.13-1 from AUR). Same 4 VMSetErrors at the end of the logfile (see attached).
Comment by Jacobo (Jacobo) - Thursday, 13 August 2020, 09:24 GMT
I have the issue too, reverted to 6.1.12-3 to fix it (kernel 5.7.12), im sorry for not having logs; I reverted quickly because I need it to work.
Comment by Christian Hesse (eworm) - Thursday, 13 August 2020, 12:01 GMT
Looks like you need to update your extension pack...
For me it does not look like a problem with the modules.
Comment by Jez Cope (jezcope) - Thursday, 13 August 2020, 12:59 GMT
Yes, I thought that too, but I have the matching extension pack for the virtualbox version. There is a cryptic note on the patch (https://github.com/archlinux/svntogit-community/commit/3a81c42c05006b60658d6b8a79aa7983663d9bab) for 6.1.12-4 that says "Use the extension pack 6.1.13.139853 if required..." but that's a pre-release version: as of today the latest version available from the main VB download page is 6.1.12, and 6.1.13.xxxxxxx is only available from https://www.virtualbox.org/wiki/Testbuilds.
Comment by Hartmut Malzahn (hwm) - Thursday, 13 August 2020, 13:03 GMT
I just updated the oracle extension pack to that 6.1.13... version and that does the trick for me with the 6.1.12-4 packages. I never thought to look for that update since usually the extension packs only update once per version, I guess.
Comment by Christian Hesse (eworm) - Thursday, 13 August 2020, 13:14 GMT
Usually you are right, but 6.1.12-4 has changes from upcoming 6.1.14. Thus the extension pack from testbuild site is required.
I already updated the extension pack package on AUR as required:
https://aur.archlinux.org/packages/virtualbox-ext-oracle/
Comment by Jacobo (Jacobo) - Friday, 21 August 2020, 13:59 GMT
Hi all,

Just updated kernel to 5.8.1 from core repo, all goes fine until I run my Win7 VM, it freezes all system (not only VM), I can't switch to terminal or even ssh the machine.

Reverting to previous kernel 5.7.12 fix the problem.

I attach a dmesg with kernel 5.7.12, any other info that I can offer please ask me.
Comment by Vladislav Glinsky (CL0NE) - Tuesday, 25 August 2020, 16:05 GMT
Can confirm that 6.1.13.xxxxxxx ext pack from testbuilds fixes the issue for linux 5.8.1 with virtualbox 6.1.12.

Loading...