Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67555 - [python-pylint] Does not support python-isort >5

Attached to Project: Arch Linux
Opened by Simon Doppler (dopsi) - Tuesday, 11 August 2020, 15:22 GMT
Last edited by Felix Yan (felixonmars) - Sunday, 16 August 2020, 08:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

python-isort was updated to 5.2.2 in testing, but pylint requires isort <5 (isort is now at 5.3.2).


Additional info:
* package versions: extra/pylint 2.5.3-1, testing/python-isort 5.2.2-1
* upstream issue: https://github.com/PyCQA/pylint/issues/3722
* isort requirement in pylint: https://github.com/PyCQA/pylint/blob/f00144fb8faa81e1ce42516c2f58eb9fc797f7bd/pylint/__pkginfo__.py#L41

Steps to reproduce:

Install python-isort from [testing] (or do a full upgrade in with [testing] enabled)
Start pylint

Terminal output:

$ pylint
Traceback (most recent call last):
File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 582, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 899, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 790, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (isort 5.2.2 (/usr/lib/python3.8/site-packages), Requirement.parse('isort<5,>=4.2.5'), {'pylint'})

# more errors....
This task depends upon

Closed by  Felix Yan (felixonmars)
Sunday, 16 August 2020, 08:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.5.3-2
Comment by Chris Billington (chrisjbillington) - Sunday, 16 August 2020, 07:56 GMT
python-isort 5.2.2 is now in [extra], so pylint is presently broken on Arch.

Upstream pull request: https://github.com/PyCQA/pylint/pull/3725

Loading...