Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67550 - [mariadb] Installation fails

Attached to Project: Arch Linux
Opened by Paul Stahl (TwentyoneThree) - Monday, 10 August 2020, 22:19 GMT
Last edited by freswa (frederik) - Tuesday, 11 August 2020, 09:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To freswa (frederik)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The installation of mariadb 10.4.13-1 (repository on mirror) and 10.4.14-1 (manually downloaded) fails on two systems in the same way:

[me@hydrogen ~] sudo pacman -Syu mariadb
:: Synchronising package databases...
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (4) jemalloc-1:5.2.1-3 mariadb-clients-10.4.13-1 mariadb-libs-10.4.13-1
mariadb-10.4.13-1

Total Installed Size: 293.92 MiB

:: Proceed with installation? [Y/n]
(4/4) checking keys in keyring [#################################] 100%
(4/4) checking package integrity [#################################] 100%
(4/4) loading package files [#################################] 100%
(4/4) checking for file conflicts [#################################] 100%
(4/4) checking available disk space [#################################] 100%
:: Processing package changes...
(1/4) installing mariadb-libs [#################################] 100%
(2/4) installing jemalloc [#################################] 100%
Optional dependencies for jemalloc
perl: for jeprof [installed]
(3/4) installing mariadb-clients [#################################] 100%
(4/4) installing mariadb [#################################] 100%
:: You need to initialize the MariaDB data directory prior to starting
the service. This can be done with mariadb-install-db command, e.g.:
mariadb-install-db --user=mysql --basedir=/usr --datadir=/var/lib/mysql
Optional dependencies for mariadb
galera: for MariaDB cluster with Galera WSREP
perl-dbd-mysql: for mysqlhotcopy, mysql_convert_table_format and mysql_setpermission
:: Running post-transaction hooks...
(1/4) Creating system user accounts...
Creating group users with gid 969.
Creating group dhcpcd with gid 968.
Creating user dhcpcd (dhcpcd privilege separation) with uid 968 and gid 968.
Creating group mysql with gid 967.
Creating user mysql (MariaDB) with uid 967 and gid 967.
Creating group nm-openconnect with gid 966.
Creating user nm-openconnect (NetworkManager OpenConnect) with uid 966 and gid 966.
Creating group nm-openvpn with gid 965.
Creating user nm-openvpn (NetworkManager OpenVPN) with uid 965 and gid 965.
Creating group tss with gid 964.
Creating user tss (tss user for tpm2) with uid 964 and gid 964.
/etc/gshadow: Group "users" already exists.
Failed to write files: File exists
error: command failed to execute correctly
(2/4) Reloading system manager configuration...
(3/4) Creating temporary files...
/usr/lib/tmpfiles.d/dhcpcd.conf:1: Failed to resolve user 'dhcpcd': No such process
/usr/lib/tmpfiles.d/dhcpcd.conf:2: Failed to resolve user 'dhcpcd': No such process
/usr/lib/tmpfiles.d/mariadb.conf:1: Failed to resolve user 'mysql': No such process
/usr/lib/tmpfiles.d/mariadb.conf:2: Failed to resolve user 'mysql': No such process
/usr/lib/tmpfiles.d/tpm2-tss-fapi.conf:2: Failed to resolve user 'tss': No such process
Failed to parse ACL "default:group:tss:rwx": Invalid argument. Ignoring
/usr/lib/tmpfiles.d/tpm2-tss-fapi.conf:4: Failed to resolve user 'tss': No such process
Failed to parse ACL "default:group:tss:rwx": Invalid argument. Ignoring
error: command failed to execute correctly
(4/4) Arming ConditionNeedsUpdate...

A mysql user is not created.
This task depends upon

Closed by  freswa (frederik)
Tuesday, 11 August 2020, 09:34 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Monday, 10 August 2020, 23:14 GMT
Sounds like you've got a problem with /etc/passwd or /etc/group. Are they immutable? Append only?
Comment by Paul Stahl (TwentyoneThree) - Tuesday, 11 August 2020, 06:13 GMT
Neither the immutable nor the append only attribute is set for any of these files:

[me@hydrogen ~] lsattr /etc/passwd
--------------e----- /etc/passwd

[me@hydrogen ~] sudo lsattr /etc/shadow
--------------e----- /etc/shadow

[me@hydrogen ~] sudo lsattr /etc/gshadow
--------------e----- /etc/gshadow

[me@hydrogen ~] sudo lsattr /etc/group
--------------e----- /etc/group
Comment by Paul Stahl (TwentyoneThree) - Tuesday, 11 August 2020, 06:28 GMT
Seems the problem was a discrepancy between /etc/group and /etc/gshadow of unknown origin ... after resolving that manually, the installation worked.

Loading...