Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67539 - [syslog-ng] 3.28.1-2 does not start

Attached to Project: Arch Linux
Opened by Miha Verlic (fluke571) - Sunday, 09 August 2020, 21:53 GMT
Last edited by Florian Pritz (bluewind) - Saturday, 29 August 2020, 09:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Florian Pritz (bluewind)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:

syslog-ng 3.28.1-2 deadlocks at start. Probably same bug as https://bugs.archlinux.org/task/65206 resurfaced again; downgrading libcap to 2.37 and syslog-ng to 3.28.1-1 helps.
This task depends upon

Closed by  Florian Pritz (bluewind)
Saturday, 29 August 2020, 09:43 GMT
Reason for closing:  Fixed
Additional comments about closing:  syslog-ng 3.28.1-3
Comment by Florian Pritz (bluewind) - Monday, 10 August 2020, 22:16 GMT
Please test with syslog-ng 3.28.1-3 from [testing]. This might be a duplicate of https://bugs.archlinux.org/task/67545
Comment by Miha Verlic (fluke571) - Tuesday, 11 August 2020, 07:45 GMT
3.28.1-3 works. Not sure why this would break in my use case, since I'm only using syslog-ng as network receiver and I dont even read anything from local systemd/journald.
Comment by Eivind (mokkurkalve) - Tuesday, 11 August 2020, 14:14 GMT
In my case the syslog-ng@default.service was being constantly restarted with 3.28.1-2. This problem seems to be fixed with 3.28.1-3. AFAIK my setup works again.
Comment by David Wheeler (dwheeler) - Tuesday, 11 August 2020, 16:03 GMT
3.28.1-3 fixes the issues I was seeing. Service starts OK, and all the logs are being written to as expected.
Comment by Klaus Alexander Seistrup (kseistrup) - Tuesday, 11 August 2020, 16:31 GMT
When I installed v3.28.1-3, some programs complained they couldn't open `/dev/log` (device was present and had correct permissions: 0666). Running `logger -t test "Is /dev/log availble?"` would fail.
Comment by Klaus Alexander Seistrup (kseistrup) - Wednesday, 12 August 2020, 04:28 GMT
Specifically:

```
$ logger -t test "Is /dev/log availble?"
logger: socket /dev/log: Connection refused
$ /bin/ls -l /dev/log
srw-rw-rw- 1 root root 0 Aug 12 06:17 /dev/log
```
Comment by Lone_Wolf (Lone_Wolf) - Wednesday, 12 August 2020, 14:18 GMT
On my system /dev/log is a symlink .
Did you reboot after installing syslog-ng 3.28.1-3 ?

$ ls -l /dev/log
lrwxrwxrwx 1 root root 28 12 aug 15:56 /dev/log -> /run/systemd/journal/dev-log
$ ls -l /run/systemd/journal/dev-log
srw-rw-rw- 1 root root 0 12 aug 15:56 /run/systemd/journal/dev-log
$
Comment by Klaus Alexander Seistrup (kseistrup) - Wednesday, 12 August 2020, 14:45 GMT
I didn't reboot, I just restarted syslog-ng. After I rebooted /dev/log became a symlink and logger(1) is working again. Thanks.

Loading...