Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67518 - [compiler-rt] compile error with clang++

Attached to Project: Arch Linux
Opened by soloturn (soloturn) - Friday, 07 August 2020, 10:00 GMT
Last edited by freswa (frederik) - Friday, 07 August 2020, 14:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

this is no real bug report as the package works. but as building the apple swift package fails with this error i'd be interested if you have a quick idea what it could be, that compiler-rt cannot be built with clang++.


$ export CC=clang
$ export CC=clang
$ makepkg -s

and it really gives the same error when compiling swift.
/usr/bin/clang++ -I../lib/tsan/dd/../.. -D_FORTIFY_SOURCE=2 -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -Wall -std=c++14 -Wno-unused-parameter -O3 -DNDEBUG -m64 -fno-lto -fPIC -fno-builtin -fno-exceptions -fomit-frame-pointer -funwind-tables -fno-stack-protector -fno-sanitize=safe-stack -fvisibility=hidden -fno-lto -O3 -gline-tables-only -Wno-gnu -Wno-variadic-macros -Wno-c99-extensions -Wno-non-virtual-dtor -fno-rtti -MD -MT lib/tsan/dd/CMakeFiles/clang_rt.dd-x86_64.dir/dd_interceptors.cpp.o -MF lib/tsan/dd/CMakeFiles/clang_rt.dd-x86_64.dir/dd_interceptors.cpp.o.d -o lib/tsan/dd/CMakeFiles/clang_rt.dd-x86_64.dir/dd_interceptors.cpp.o -c ../lib/tsan/dd/dd_interceptors.cpp
../lib/tsan/dd/dd_interceptors.cpp:225:1: warning: attribute declaration must precede definition [-Wignored-attributes]
..._NTH (realpath (const char *restrict __name, char *_restrict __resolved))
^
../lib/tsan/dd/dd_interceptors.cpp:225:20: error: redefinition of 'realpath'
...

This task depends upon

Closed by  freswa (frederik)
Friday, 07 August 2020, 14:43 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Please use the forum, the irc or the ML to ask for support.
Thank you

Loading...