Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67499 - [vicious][awesome] vicious is unusable in current awesome

Attached to Project: Community Packages
Opened by Stanislav T (stas-t) - Wednesday, 05 August 2020, 20:11 GMT
Last edited by Anatol Pomozov (anatolik) - Thursday, 06 August 2020, 23:58 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Anatol Pomozov (anatolik)
Levente Polyak (anthraxx)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description: cannot use vicious in awesome after switching vicious to lua 5.4

It looks like after upgrading lua to 5.4 vicious was upgraded as well but awesome was kept with lua 5.3. It makes little sense since vicious is required by awesome.

Additional info:
* package version(s)
awesome 4.3-2
vicious 2.4.1-1
lua53 5.3.5-1
lua53-lgi 0.9.2-3
lua 5.4.0-2

Steps to reproduce:

add a line to rc.lua:

vicious = require("vicious")

and you'll get the error&traceback as in the file attached.
This task depends upon

Closed by  Anatol Pomozov (anatolik)
Thursday, 06 August 2020, 23:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  vicious 2.4.1-2
Comment by Stanislav T (stas-t) - Thursday, 06 August 2020, 17:19 GMT
  • Field changed: Percent Complete (100% → 0%)
Ok, now both tickets are closed. But is the issue with awesome and vicious resolved?

Also I agree that the two issues are similar, but I don't agree that they are duplicate since they are concerning different packages and different versions of lua.
Comment by Anatol Pomozov (anatolik) - Thursday, 06 August 2020, 18:48 GMT
If awesome uses 5.3 then vicious should be consistent with it.

I attached a PKGBUILD that reverts vicious back to lua 5.3. Folks could you please check if it works for you?
   PKGBUILD (1.1 KiB)
Comment by Stanislav T (stas-t) - Thursday, 06 August 2020, 18:59 GMT
Yes, it's fixed with the new PKGBUILD: there is no error on startup anymore and my only widget is back, thank you!

Loading...