Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67488 - [virtualbox-host-modules-arch] no current module for linux 5.8.arch1-1

Attached to Project: Community Packages
Opened by David McInnis (daavve) - Tuesday, 04 August 2020, 18:17 GMT
Last edited by Christian Hesse (eworm) - Monday, 07 September 2020, 21:29 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Christian Hesse (eworm)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No

Details

Package Combinations:

local/linux 5.8.arch1-1
local/virtualbox 6.1.12-3
local/virtualbox-host-modules-arch 6.1.12-5


1) Enable testing & community-testing repository

2) Update packages.

3) Notice Linux gets updated, but virtualbox-host-modules-arch does not get updated.

4) Reboot computer and start virtualbox. You get a message:

$ WARNING: The vboxdrv kernel module is not loaded. Either there is no module
available for the current kernel (5.8.0-arch1-1) or it failed to
load. Please recompile the kernel module and install it by

sudo /sbin/vboxconfig

You will not be able to start VMs until this problem is fixed
This task depends upon

Closed by  Christian Hesse (eworm)
Monday, 07 September 2020, 21:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  virtualbox 6.1.14-1
Comment by Laurent Carlier (lordheavy) - Thursday, 06 August 2020, 07:57 GMT Comment by Lone_Wolf (Lone_Wolf) - Saturday, 08 August 2020, 19:37 GMT
Looks like upstream tracks this at https://www.virtualbox.org/ticket/19644
Comment by Jan Alexander Steffens (heftig) - Saturday, 08 August 2020, 19:39 GMT
FTR I do not consider VirtualBox a reason to hold back Linux 5.8 from [core] indefinitely. I plan to move 5.8.1 once it's signed off. Please move to linux-lts if this issue has not been resolved by then.
Comment by loqs (loqs) - Saturday, 08 August 2020, 22:23 GMT
The patch lordheavy found looks to composed of revisions 85208 r85430 r85431 r85432 r85504 r85505 r85514 r85516 r85518 from https://www.virtualbox.org/svn/vbox/trunk
Extracting those to revisions with svn diff -c r##### --git https://www.virtualbox.org/svn/vbox/trunk > r#####.patch adding to the PKGBUILD the result then builds for 5.8.arch1-1.

Attached diff of changes and src archive for easy building.
Comment by Christian Hesse (eworm) - Saturday, 08 August 2020, 23:14 GMT
It does build. But will the modules load and run a VM?
The patch referenced above indicates that the modules fail with missing globals on loading.
Comment by loqs (loqs) - Sunday, 09 August 2020, 00:31 GMT
The difference after applying the two patches excluding comments is in src/VBox/HostDrivers/Support/linux/SUPDrv-linux.c.
A rearranging of #if LINUX_VERSION_CODE which should produce the same result.
A difference in the value of # define EXEC_MEMORY_SIZE r85504 changed the values to 10MB ifdef DEBUG else 8MB,
the original patch did not change the values of 8MB ifdef DEBUG else 2MB.
I do not use VirtualBox so I only build tested it. I doubt the change would fix the modules failing to load.

Sorry for the noise.
Comment by Christian Hesse (eworm) - Monday, 10 August 2020, 07:16 GMT
Your work is welcome, so do not worry.
It's a good starting point, but we are missing some important bits.
Comment by loqs (loqs) - Tuesday, 11 August 2020, 08:18 GMT
This adds almost every revision for bugref:9801 which appears to be the fix for ticket 19644, r85602, r85603, r85604 were not added as they were marked Solaris.

If that still does not work https://www.virtualbox.org/attachment/ticket/19644/local_patches exports the kernel symbols which was reported to work with the original patch.
Comment by Christian Hesse (eworm) - Tuesday, 11 August 2020, 08:47 GMT
That looks promising... Much appreciated!
Stay tuned...
Comment by Christian Hesse (eworm) - Tuesday, 11 August 2020, 09:22 GMT
Well, it runs VMs on a host with linux 5.8, but loading the extension pack is broken. :-/
Comment by loqs (loqs) - Tuesday, 11 August 2020, 22:16 GMT
What about using the test build [1] of the extension pack?

[1] https://www.virtualbox.org/wiki/Testbuilds
Comment by Christian Hesse (eworm) - Wednesday, 12 August 2020, 06:56 GMT
I tried all, but could not find one that works.
Comment by Christian Hesse (eworm) - Wednesday, 12 August 2020, 08:37 GMT
The testbuild files have been updated, we have working extension pack now.
Everything should be sorted already, please give it a try!

Thanks a lot to loqs for his hard work!
Comment by Magnus Boman (katt) - Wednesday, 12 August 2020, 21:25 GMT
  • Field changed: Percent Complete (100% → 0%)
Still broken as of 6.1.12-4
Comment by Christian Hesse (eworm) - Wednesday, 12 August 2020, 21:26 GMT
So what's your issue here?
Comment by Christian Hesse (eworm) - Wednesday, 12 August 2020, 22:02 GMT
I missed to rebuild virtualbox-host-modules-arch in [community] for linux 5.7.12, rebuilding for [community-testing] was not enough...
Please update and try again.
Comment by Magnus Boman (katt) - Wednesday, 12 August 2020, 22:20 GMT
The issue is that while VMs start, as soon as I start actually doing something in them (even just downloading something in curl) virtualbox will crash.
[ 1019.811937] BUG: kernel NULL pointer dereference, address: 0000000000000044

Happens on both linux-zen and linux, see attached logs.
Comment by Christian Hesse (eworm) - Thursday, 13 August 2020, 07:31 GMT
I do not see this... Anybody else?
Comment by Magnus Boman (katt) - Thursday, 13 August 2020, 11:48 GMT
Hm, I can't seem to make it crash with an arch livecd, but using a gentoo livecd and trying to download anything (tried archiso, gentoo stage3 tarball) makes it crash within a few seconds. Could this be a gentoo issue? I'd like to think the guest wouldn't crash like that though...
   crash.mp4 (816.3 KiB)
Comment by Barry G (smartiq) - Tuesday, 18 August 2020, 22:11 GMT
I just started hitting:
BUG: kernel NULL pointer dereference, address: 0000000000000044

On my Arch host with an Ubuntu 20.04 guest.

Relevant host packages:
linux 5.8.1.arch1-1
virtualbox 6.1.12-4
virtualbox-host-modules-arch 6.1.12-9

Comment by Daniel Johnson (Dano) - Wednesday, 19 August 2020, 16:06 GMT
I just hit this as well on my Arch host with an Ubuntu 16.04 guest.

[165918.167350] BUG: kernel NULL pointer dereference, address: 0000000000000044
[165918.167358] #PF: supervisor write access in kernel mode
[165918.167361] #PF: error_code(0x0002) - not-present page

Packages:
linux - 5.8.1.arch1-1
virtualbox - 6.1.12-4
virtualbox-host-dkms - 6.1.12-4
Comment by Octavia Togami (octylFractal) - Thursday, 20 August 2020, 22:16 GMT
Worse on my end -- with BTRFS as my filesystem and linux-zen (5.8.1-zen1-1-zen), my computer will just freeze upon starting VirtualBox with a Windows 10 VM. 5.7.12 does not have this issue. No logs on my end as the entire computer simply freezes.
Comment by Adrian (adriaticc) - Tuesday, 01 September 2020, 13:01 GMT
@octylFractal, any success with test build 6.1.13 r140124+ (https://www.virtualbox.org/wiki/Testbuilds)?

I also experienced hard freezes and kernel panic/oops situations (flashing capslock) with virtualbox under 5.8.x kernels, but only when running other software like firefox, chromium, mpv, mplayer, glxgears, etc. This was a bit of a red herring, as all of these programs use some form of hardware-accelerated graphics, leading me to believe the issue was related to nvidia drivers on my optimus laptop (oy vey, so many potential issues there).

I finally had the time to test about 60 combinations of video drivers, bios (optimus) settings, modesetting, xorg junk, etc., and found that the issue persisted in every conceivable combination of driver and hardware support, including forced intel chipset w/xf86-video-vesa and absolutely no hardware accelerated anything. With virtualbox as the definite culprit (wish I'd realized that sooner) I tried these very recent test builds and the freezes disappeared. Builds from even a couple days ago still have the issue.

Loading...