Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67480 - [dns-lexicon] Missing dependency on python-dnspython

Attached to Project: Community Packages
Opened by Clayton Craft (craftyguy) - Tuesday, 04 August 2020, 07:41 GMT
Last edited by Felix Yan (felixonmars) - Tuesday, 04 August 2020, 17:54 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

dns-lexicon seems to depend on python-dnspython (when invoked as a part of certbot/certbot-dns-luadns at least).

> pkg_resources.DistributionNotFound: The 'dnspython<2requests[security]' distribution was not found and is required by dns-lexicon

After installing python-dnspython, this error goes away.


Steps to reproduce:

1) install certbot + certbot-dns-luadns (and probably other certbot-dns-* packages that depend on dns-lexicon? I don't know if using cerbot to repro is absolutely necessary, it's just how I did it)

2) run certbot, hit error about dns-lexicon missing dnspython
This task depends upon

Closed by  Felix Yan (felixonmars)
Tuesday, 04 August 2020, 17:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.3.28-2

Loading...