Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67386 - [firefox] options `-C embed-bitcode=no` and `-C lto` are incompatible

Attached to Project: Arch Linux
Opened by Christian Bundy (christianbundy) - Friday, 24 July 2020, 20:32 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 28 July 2020, 15:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: When trying to build from source it looks like there's a problem from the newer versions of Rust.

44:06.71 Compiling gkrust v0.1.0 (/home/christianbundy/.cache/pacman-src/packages/packages/firefox/repos/extra-x86_64/src/firefox-78.0.2/toolkit/library/rust)
44:06.89 error: options `-C embed-bitcode=no` and `-C lto` are incompatible
44:07.23 error: could not compile `gkrust`.
44:07.23 To learn more, run the command again with --verbose.

There are some release notes from Rust available here: https://github.com/rust-lang/rust/pull/74374

Steps to reproduce: makepkg
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 28 July 2020, 15:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  firefox 79.0-1
Comment by freswa (frederik) - Sunday, 26 July 2020, 14:24 GMT
Confirmed with extra-x86_64_build

Loading...