Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67373 - Wireless deauth results in wlan0 being renamed to wlan1

Attached to Project: Arch Linux
Opened by Mike Cloaked (mcloaked) - Thursday, 23 July 2020, 20:04 GMT
Last edited by freswa (frederik) - Thursday, 23 July 2020, 21:06 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Periodically the wireless connection gets a deauth event, and systemd-networkd tries to reconnect - but systemd-udevd seems to rename the interface from wlan0 to wlan1 which then reconnects and the networking then fails to work properly.


Additional info:
* package version(s)

systemd 245.6-8
iwd 1.8-1
$ uname -r
5.7.9-arch1-1
linux-firmware 20200519.8ba6fa6-1

* config and/or log files etc.

I will attach the journal log showing two changes of the wireless interface - wlano to wlan1 and wlan1 to wlan2 later in the log file.

$ cat /etc/systemd/network/10-wlan0.link
[Match]
MACAddress=0c:8b:fd:bd:27:bb

[Link]
Description=Wireless interface
Name=wlan0

$ cat /etc/systemd/network/20-wired.network
[Match]
MACAddress=20:1a:06:5e:83:60

[Network]
Description=lenovo1

DHCP=yes
IPv6PrivacyExtensions=true

[Address]
# ULA
Address=fd00:abad:f00d:d00d::93/64

[DHCP]
RouteMetric=10

$ cat /etc/systemd/network/25-wireless.network
[Match]
Name=wlan0

[Network]
Description=lenovo1w

DHCP=yes
IPv6PrivacyExtensions=true


[Address]
# ULA
Address=fd00:abad:f00d:d00d::94/64
#

[DHCP]
RouteMetric=20

/etc/iwd/main.conf is not present on the system

* link to upstream bug report, if any

Steps to reproduce:

Boot, system runs correctly with wlan0 running normally. After some random period the networking breaks, and I cannot ping a machine on the LAN by name or an external machine by name. Running ifconfig shows that the initially defined wlan0 has become wlan1. After a further period wlan1 becomes wlan2

It seems that key lines in the log are:

Jul 23 19:10:47 lenovo1 systemd-udevd[3006]: wlan0: Failed to get link config: No such device
Jul 23 19:10:47 lenovo1 systemd-udevd[2999]: Using default interface naming scheme 'v245'.
Jul 23 19:10:47 lenovo1 systemd-networkd[451]: wlan1: Link UP
Jul 23 19:10:47 lenovo1 systemd-udevd[2999]: ethtool: autonegotiation is unset or enabled, the speed and duplex a>
Jul 23 19:10:47 lenovo1 systemd-udevd[2999]: wlan1: Failed to rename network interface 6 from 'wlan1' to 'wlan0':>
Jul 23 19:10:47 lenovo1 systemd-udevd[2999]: wlan1: Failed to process device, ignoring: Device or resource busy

and

ul 23 19:41:08 lenovo1 kernel: iwlwifi 0000:04:00.0: Microcode SW error detected. Restarting 0x2000000.
Jul 23 19:41:08 lenovo1 kernel: iwlwifi 0000:04:00.0: Start IWL Error Log Dump:
Jul 23 19:41:08 lenovo1 kernel: iwlwifi 0000:04:00.0: Status: 0x00000040, count: 6

as well as
Jul 23 19:41:08 lenovo1 kernel: iwlwifi 0000:04:00.0: Collecting data: trigger 2 fired.
Jul 23 19:41:08 lenovo1 kernel: ieee80211 phy1: Hardware restart was requested

and

Jul 23 19:41:08 lenovo1 kernel: iwlwifi 0000:04:00.0: Collecting data: trigger 2 fired.
Jul 23 19:41:08 lenovo1 kernel: ieee80211 phy1: Hardware restart was requested

Jul 23 19:41:10 lenovo1 kernel: iwlwifi 0000:04:00.0: failed to update power mode
Jul 23 19:41:10 lenovo1 kernel: iwlwifi 0000:04:00.0: failed to update CQM thresholds

which leads to
Jul 23 19:41:10 lenovo1 kernel: iwlwifi 0000:04:00.0: Failed sending remove station
Jul 23 19:41:10 lenovo1 iwd[4744]: Received Deauthentication event, reason: 3, from_ap: false

Jul 23 19:41:10 lenovo1 systemd-networkd[451]: wlan1: Link DOWN
Jul 23 19:41:10 lenovo1 systemd-networkd[451]: wlan1: Lost carrier

and then to
Jul 23 19:41:10 lenovo1 systemd-networkd[451]: wlan0: Could not find device, waiting for device initialization: N>
Jul 23 19:41:10 lenovo1 systemd-udevd[5483]: wlan0: Failed to get link config: No such device
Jul 23 19:41:10 lenovo1 systemd-udevd[5480]: Using default interface naming scheme 'v245'.
Jul 23 19:41:10 lenovo1 systemd-networkd[451]: wlan2: Link UP
Jul 23 19:41:10 lenovo1 systemd-udevd[5480]: ethtool: autonegotiation is unset or enabled, the speed and duplex a>
Jul 23 19:41:10 lenovo1 systemd-udevd[5480]: wlan2: Failed to rename network interface 9 from 'wlan2' to 'wlan0':>

The wireless device is
04:00.0 Network controller: Intel Corporation Wireless 7260 (rev 73)
Subsystem: Intel Corporation Wireless-N 7260

Is it possible this is a firmware bug?

$ lsmod | grep iwl
iwlmvm 462848 0
mac80211 1040384 1 iwlmvm
iwlwifi 393216 1 iwlmvm
cfg80211 897024 3 iwlmvm,iwlwifi,mac80211
This task depends upon

Closed by  freswa (frederik)
Thursday, 23 July 2020, 21:06 GMT
Reason for closing:  Not a bug
Additional comments about closing:  This rather seems to be a configuration issue than a packaging issue. Please ask in the forums, the irc or the ml for help.
Thank you :)

Loading...