Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67371 - [crda] 85-regulatory.rules caused '/usr/bin/set-wireless-regdom' failed with exit code 1.

Attached to Project: Arch Linux
Opened by Michael (ZeroBeat) - Thursday, 23 July 2020, 16:49 GMT
Last edited by freswa (frederik) - Saturday, 12 September 2020, 16:22 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

85-regulatory.rules caused cfg80211: Process '/usr/bin/set-wireless-regdom' failed with exit code 1.
$ journalctl | grep cfg80211
Jul 08 15:42:34 tux1 systemd-udevd[415]: cfg80211: Process '/usr/bin/set-wireless-regdom' failed with exit code 1.

on
$ uname -r
5.7.9-arch1-1
This task depends upon

Closed by  freswa (frederik)
Saturday, 12 September 2020, 16:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  5.8.7-arch1-1
Comment by loqs (loqs) - Thursday, 23 July 2020, 18:28 GMT
If you downgrade wireless-regdb to 2019.06.03-1 can you reproduce the issue?
Comment by Michael (ZeroBeat) - Thursday, 23 July 2020, 18:35 GMT
I'll check it. At the moment, I think about it, to remove the whole crda and regulatory stuff from
my (penetration testing) systems, because this issue causes several other issues:
https://bugzilla.kernel.org/show_bug.cgi?id=208483
https://github.com/openwrt/mt76/issues/425

Comment by Michael (ZeroBeat) - Thursday, 23 July 2020, 19:01 GMT
Downgrading lead to more issues:
cfg80211: failed to load regulatory.db
8821ce: Unknown symbol __cfg80211_alloc_event_skb (err -2)
8821ce: Unknown symbol cfg80211_remain_on_channel_expired (err -2)
...

and we have to downgrade much more packages.

Unfortunately the issue prevent to inject packets on 5GHz.


Comment by Michael (ZeroBeat) - Thursday, 23 July 2020, 22:23 GMT
Looks like the issue exist since last year (on other distros, too):
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=810384

wireless-regdom is set according to https://wiki.archlinux.org/index.php/Network_configuration/Wireless
$ cat /etc/conf.d/wireless-regdom | grep -v "#"
WIRELESS_REGDOM="DE"

and country is definitely not set:
$ dmesg | grep cfg
[ 5.926802] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[ 5.930678] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'

that makes the whole system restricted as hell.




Comment by Michael (ZeroBeat) - Friday, 24 July 2020, 08:12 GMT
We should also take a closer look at libnl. It could be possible that libnl caused the issue.

Comment by Michael (ZeroBeat) - Saturday, 12 September 2020, 15:26 GMT
Issue solved on
$ uname -r
5.8.7-arch1-1

Loading...