Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#67302 - makepkg strip results in segfault.

Attached to Project: Pacman
Opened by Bradley Nelson (bcnelson) - Thursday, 16 July 2020, 19:08 GMT
Last edited by Allan McRae (Allan) - Friday, 17 July 2020, 03:04 GMT
Task Type Bug Report
Category makepkg
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 5.2.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Summary and Info: Running makepkg with the strip option results in a segfault.


Steps to Reproduce:
1. get the PKGBUILD version 1.1.0-2 from https://aur.archlinux.org/packages/stacer-bin/
2. run makepkg -si
3. Try to open resulting executable

Removing strip option results in a useable executable
This task depends upon

Closed by  Allan McRae (Allan)
Friday, 17 July 2020, 03:04 GMT
Reason for closing:  Not a bug
Comment by Eli Schwartz (eschwartz) - Thursday, 16 July 2020, 19:51 GMT
I do not understand why you think this is a makepkg bug. If the executable breaks, there is likely something wrong with it. For example, AppImage files are executables with faked sections that actually contain compressed archives which the /usr/bin/strip program tries to remove.

If the executable isn't broken, it would still be a bug in strip, not makepkg.
Comment by Bradley Nelson (bcnelson) - Friday, 17 July 2020, 02:03 GMT
Sorry I didn't realize that strip was a separate tool.

Loading...