Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67287 - [chromium] desktop entry registers x-scheme-handler/ftp

Attached to Project: Arch Linux
Opened by Peter Weber (hoschi) - Wednesday, 15 July 2020, 15:53 GMT
Last edited by freswa (frederik) - Wednesday, 15 July 2020, 16:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Hello!

Description:
The file 'chromium.desktop' registers for MimeType "x-scheme-handler/ftp". Therefore Chromium tries to open every file which is available via FTP protocol.


Additional info:
* package version(s): 83.0.4103.116-3
* config and/or log files etc.: /usr/share/applications/chromium.desktop
* link to upstream bug report, if any: https://gitlab.gnome.org/GNOME/glib/-/issues/1414

Steps to reproduce:
1.) Install chromium
2.) Open a FTP connection with Nautilus
3.) Double click any file -> chromium always tries to open the file

What should happen:
The assigned application should open the files. For examples 'gedit' shall be used for 'txt' files, when assigend to 'text/plain'.

Workaround:
# pacman -Rns chromium
The other webbrowsers like Epiphany or Firefox don't register themselves for 'x-scheme-handler/ftp' and cause no issues.

Thanks


PS: Furthermore Chromium is rather invasive. It also registers for png, jpeg and gif and so on. None of that is the job of a webbrowser.
This task depends upon

Closed by  freswa (frederik)
Wednesday, 15 July 2020, 16:21 GMT
Reason for closing:  Not a bug
Comment by freswa (frederik) - Wednesday, 15 July 2020, 16:21 GMT
The handler only defines the ability of an application to handle certain MIME-Types. There can be multiple applications installed on a system which may be able to handle the same MIME-Type though.
It's upon the user to choose the application to open a certain MIME-Type with as he/she likes.

Loading...