Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67269 - [gitlab] 13.1.4-1 can't delete project "no implicit conversion of nil into String"

Attached to Project: Community Packages
Opened by Marcus Hoffmann (BubuIIC) - Monday, 13 July 2020, 23:12 GMT
Last edited by Anatol Pomozov (anatolik) - Thursday, 16 July 2020, 01:58 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Anatol Pomozov (anatolik)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

### Summary
Deleting any project fails with this message

> This project was scheduled for deletion, but failed with the following message: no implicit conversion of nil into String

See https://git.bubu1.eu/Bubu/test

### Steps to reproduce

* Create a project
* Try to delete project
* Go to project page, see the banner about failed deletion

Reported upstream here: https://gitlab.com/gitlab-org/gitlab/-/issues/228747

There doesn't seem to be many helpful logs, some log output is in the upstream issue.
This task depends upon

Closed by  Anatol Pomozov (anatolik)
Thursday, 16 July 2020, 01:58 GMT
Reason for closing:  Not a bug
Comment by Marcus Hoffmann (BubuIIC) - Wednesday, 15 July 2020, 23:46 GMT
This turned out to be a configuration error (enabling the container registry where no registry is reachable) with no real error message for that failure path.

Loading...