Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67261 - [nvidia-prime] 1.0.4 results in no display devices found

Attached to Project: Arch Linux
Opened by no way (evilrobotoverlord) - Monday, 13 July 2020, 07:25 GMT
Last edited by freswa (frederik) - Tuesday, 14 July 2020, 14:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giancarlo Razzolini (grazzolini)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: On upgrading nvidia-prime from 1.0.3 to 1.0.4, gdm fails to start.


Additional info:
* nvidia-prime 1.0.4, nvidia-utils 450.57-2, nvidia 450.57-1, xorg-server 1.20.8-2, gdm 3.36.2-1, Linux 5.7.7-arch1-1 x86_64
* http://ix.io/2rvQ (where it says "No enabled display devices found"), http://ix.io/2rw0 (xorg.conf, generated by X -configure), http://ix.io/2rvS (output of nvidia-xconfig --query-gpu-info)
* downgrading to 1.0.3 makes it work just fine, the issue just cropped up after upgrading to 1.0.4

Steps to reproduce:
* upgrade nvidia-prime from 1.0.3 to 1.0.4
* boot
This task depends upon

Closed by  freswa (frederik)
Tuesday, 14 July 2020, 14:37 GMT
Reason for closing:  Not a bug
Additional comments about closing:  reporter: bad config
Comment by Giancarlo Razzolini (grazzolini) - Monday, 13 July 2020, 15:44 GMT
Ok, let's tackle this in steps:
1) You aren't supposed to use a xorg configuration with prime render offload
2) It seems from your X log that you're using reverse prime, instead of render offload
3) The AllowGPUScreen option is now present on the driver and Xorg, so it's not necessary anymore

If you plan on using reverse prime, I suggest you remove nvidia-prime, at all. You don't need the prime-run script as well, because everything is run on the nvidia card.

Loading...