Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67171 - [firefox-developer-edition] upgrade flipped "network.http.spdy.enforce-tls-profile" true

Attached to Project: Community Packages
Opened by Brian (FoOBAkXe6qb31hurHdey) - Wednesday, 01 July 2020, 22:08 GMT
Last edited by Andrew Crerar (andrewSC) - Wednesday, 26 August 2020, 17:38 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Andrew Crerar (andrewSC)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
tl;dr: upgraded from 78.0b9-1 to 79.0b2-1 and unexpectedly the boolean value for "network.http.spdy.enforce-tls-profile" in the config was flipped true - causing no websites with https to load


I was on my computer, Arch current kernel x86_64, and I saw there was a newer version of firefox-developer-edition ready - I downloaded the package from the webpage: https://www.archlinux.org/packages/community/x86_64/firefox-developer-edition/

ran yay -Udd firefox-developer-edition-79.0b2-1-x86_64.pkg.tar.zst
and then pkill firefox to kill my current firefox-developer-edition session - went back to the gui to open the firefox-developer-edition, firefox would no longer load any https:// webpages, giving the error: NS_ERROR_NET_INADEQUATE_SECURITY but with no option to continue or for more information. After googling I found some information that network.http.spdy.enforce-tls-profile might have been flipped true and sure enough it turning the value false in the config resolved the issue.

There are a couple mentions of that config option in the bugzilla on mozilla and mention that it is a non-standard option - and can be safely turned off, however they are quite old mentions.

https://bugzilla.mozilla.org/show_bug.cgi?id=1321116
https://bugzilla.mozilla.org/show_bug.cgi?id=1321252

I mostly wanted to catalog this error because truly it was a real pain to resolve.
This task depends upon

Closed by  Andrew Crerar (andrewSC)
Wednesday, 26 August 2020, 17:38 GMT
Reason for closing:  Not a bug

Loading...