Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67147 - [strawberry] Dependency on libimobiledevice missing

Attached to Project: Community Packages
Opened by Guillaume Racicot (gracicot) - Monday, 29 June 2020, 13:13 GMT
Last edited by Antonio Rojas (arojas) - Monday, 29 June 2020, 16:28 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Dependency on libimobiledevice missing, the application cannot start

Additional info:
strawberry package version 0.6.12-2

Steps to reproduce:
* Install the package at the mentioned version
* Try running the application

*Observed result:*

The application don't start and output `strawberry: error while loading shared libraries: libimobiledevice-1.0.so.6: cannot open shared object file: No such file or directory`

*Expected result:*

The application starts
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 29 June 2020, 16:28 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Monday, 29 June 2020, 13:31 GMT
It depends on libgpod, which depends on libimobiledevice, so it should work unless you're doing partial updates. The new guidelines say this isn't good enough, though.
Comment by Doug Newgard (Scimmia) - Monday, 29 June 2020, 16:14 GMT
Antonio, as I pointed out, the partial update doesn't really matter. Current package guidelines require all first level deps to be listed.
Comment by Antonio Rojas (arojas) - Monday, 29 June 2020, 16:28 GMT
What does this have to do with this report? The user did a partial upgrade, this would have happened with or without listing first-level dependencies.

Loading...