Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67105 - [qt5-webengine] [libpng] Some APNG flicker when playing

Attached to Project: Arch Linux
Opened by Florian Bruhin (The-Compiler) - Thursday, 25 June 2020, 11:54 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 09 July 2020, 16:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Antonio Rojas (arojas)
Christian Hesse (eworm)
Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Similarly to  FS#55093 , some animated PNGs flicker when viewing them with a QtWebEngine-based browser on Archlinux, due to Arch's patching of libpng:
https://bugs.chromium.org/p/chromium/issues/detail?id=752403#c10

The Chromium package fixed the issue by switching to Chromium's bundled libpng:
https://git.archlinux.org/svntogit/packages.git/commit/trunk/PKGBUILD?h=packages/chromium&id=52c7a37d2ba0a018f2b23b22483bd06c3e0459e5

Additional info:
* package version(s): qt5-webengine 5.15.0-2, libpng 1.6.37-2

Steps to reproduce:
Use a QtWebEngine based browser such as falkon or qutebrowser and visit https://upload.wikimedia.org/wikipedia/commons/1/14/Animated_PNG_example_bouncing_beach_ball.png

This can likely be fixed by either removing Arch's libpng patch (though I suppose there's a good reason for it to be there?) or by telling QtWebEngine to use the system libpng instead. I'm not sure what the proper qmake argument would be, I'm guessing either "-no-system-png" or "-no-feature-webengine-system-png".
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 09 July 2020, 16:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  libpng 1.6.37-3
Comment by Antonio Rojas (arojas) - Saturday, 27 June 2020, 17:08 GMT
I'm not very fond of using the bundled version of such a critical library.
The PKGBUILD says about the patch: "Required by Firefox". But firefox is not compiled with system libpng. What is the rationale then for including this unofficial patch, given that it breaks (at least) chromium and qt?
Comment by Jan de Groot (JGC) - Tuesday, 30 June 2020, 07:34 GMT Comment by Antonio Rojas (arojas) - Monday, 06 July 2020, 19:11 GMT
@eworm what's your take on this?
Comment by Christian Hesse (eworm) - Monday, 06 July 2020, 21:24 GMT
No objections from me.
As nobody else complained... I will drop the patch.

Loading...