Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67093 - [gnutls] Missing library - libgnutls-openssl-27.0.2

Attached to Project: Arch Linux
Opened by Mike Bair (mbair) - Tuesday, 23 June 2020, 23:21 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 24 June 2020, 05:09 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I suggest you add the switch --enable-openssl-compatibility to the configure command for this project ( gnutls-3.6.14 ). This will cause the compiler to generate the library libgnutls-openssl-27.0.2 which is missing otherwise.

Problem:
When some browsers ( firefox-66 and palemoon at least) attempt to connect to an encrypted web site - specifically on an AKAMAI hosted web site - and this library is not available, the AKAMAI hosting site returns the message "An error occurred while processing your request" along with a reference number which is only usable to AKAMAI, and apparently the error is not even returned to the encrypted web site so the encrypted web site has no knowledge that an error has occurred. The web browser handles the missing library transparently and does not generate an error although communication with the encrypted web site fails.

Solution:
With the library available, it is loaded by the web browser and communication with the encrypted web site and thru AKAMAI proceeds normally.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 24 June 2020, 05:09 GMT
Reason for closing:  Implemented
Additional comments about closing:  3.6.14-2

Loading...