Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67076 - telegram-desktop needs libaom (old version)

Attached to Project: Community Packages
Opened by Evert Mouw (evert_mouw) - Monday, 22 June 2020, 14:12 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 22 June 2020, 14:40 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

- The telegram-desktop package needs aom, but it is not in the dependencies.
- Also it needs an old version of aom.

telegram-desktop 2.1.12-1
aom 2.0.0-1

On IRC #archlinux it was suggested that an old version of libaom is needed:

<grawity> ?pkgfile libaom.so.0
<EMIYA> grawity: no results for 'libaom.so.0'

ldd /usr/bin/telegram-desktop

libaom.so.0 => not found

pacman -Qi telegram-desktop

Name : telegram-desktop
Version : 2.1.12-1
Description : Official Telegram Desktop client
Architecture : x86_64
URL : https://desktop.telegram.org/
Licenses : GPL3
Groups : None
Provides : None
Depends On : hunspell ffmpeg hicolor-icon-theme lz4 minizip openal qt5-imageformats xxhash libdbusmenu-qt5
Optional Deps : ttf-opensans: default Open Sans font family [installed]
Required By : None
Optional For : purpose
Conflicts With : None
Replaces : None
Installed Size : 45.21 MiB
Packager : Sven-Hendrik Haase <svenstaro@gmail.com>
Build Date : Thu 18 Jun 2020 07:49:18 AM CEST
Install Date : Mon 22 Jun 2020 03:15:00 PM CEST
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

Steps to reproduce:

run:

telegram-desktop on a terminal
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 22 June 2020, 14:40 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Nothing in telegram-desktop is linked to libaom.so.* at all

Loading...