Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67066 - pacman -Syu without reboot can break kernel modules

Attached to Project: Arch Linux
Opened by Volker WeiƟmann (volker_weissmann) - Sunday, 21 June 2020, 13:15 GMT
Last edited by Eli Schwartz (eschwartz) - Sunday, 21 June 2020, 13:19 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Steps to reproduce:

1. Wait for a new kernel update
2. Remove any usb drives
3. Reboot
4. Run lsmod to check if usb_storage is loaded, it shouldn't be
5. Run pacman -Syu
6. Insert a usb drive. It won't work because pacman -Syu deleted /lib/modules/old-kernel , therefore usb_storage can't be loaded.


Recommended way to fix it:

/lib/modules/old-kernel shouldn't be deleted while running pacman -Syu, but at the next reboot.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Sunday, 21 June 2020, 13:19 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#16702
Comment by Eli Schwartz (eschwartz) - Sunday, 21 June 2020, 13:19 GMT
Pacman will per definition delete files owned by versions of packages which have been uninstalled in order to install new versions. In order to prevent that, you'd need to, well, not uninstall the old package. That is covered by FS#16702.

Loading...