Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67055 - [libinput] does not detect USB ports

Attached to Project: Arch Linux
Opened by Robert (robson) - Saturday, 20 June 2020, 10:43 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 21 June 2020, 18:15 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After yesterday's update, libinput does not detect USB when I start the PC, which is why I have no connection to the network, and as soon as I connect, every now and then the connection is broken because the connection is wired via usb_modeswitch. I had to return to the previous version of libinput 1.15.5-1 which works fine.

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 21 June 2020, 18:15 GMT
Reason for closing:  None
Comment by Andreas Radke (AndyRTR) - Saturday, 20 June 2020, 11:43 GMT
Report this upstream with more details about your hardware and log messages:

https://gitlab.freedesktop.org/libinput/libinput
Comment by Robert (robson) - Saturday, 20 June 2020, 11:52 GMT
Bus 002 Device 003: ID 046d:c21f Logitech, Inc. F710 Wireless Gamepad [XInput Mode]
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 006: ID 12d1:14db Huawei Technologies Co., Ltd. E353/E3131
Bus 001 Device 004: ID 1c4f:0002 SiGma Micro Keyboard TRACER Gamma Ivory
Bus 001 Device 003: ID 093a:2521 Pixart Imaging, Inc. Optical Mouse
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Comment by Doug Newgard (Scimmia) - Saturday, 20 June 2020, 12:46 GMT
Wait, what does libinput have to do with your network?
Comment by Robert (robson) - Saturday, 20 June 2020, 13:11 GMT
It turned out that after installing python-pyudev as an optional libinput dependency fixed the problem.
Comment by Andreas Radke (AndyRTR) - Saturday, 20 June 2020, 13:34 GMT
Check if something here
https://lists.freedesktop.org/archives/wayland-devel/2020-June/041478.html or
https://gitlab.freedesktop.org/libinput/libinput/-/commits/1.15-branch could be the reason.

From documentation the package python-pyudev shouldn't be required for hardware to work but for use in the measure tool.
Best would be to ask upstream or maybe more user will run into this.
Comment by AK (Andreaskem) - Sunday, 21 June 2020, 08:34 GMT
Is there actually a reason to suspect libinput is at fault aside from the reporter's initial assertion which did not give much detail at all?

Some kind of log for a broken session (journalctl...) would be useful.

edit: nevermind the rest
Comment by Robert (robson) - Sunday, 21 June 2020, 10:48 GMT
The problem is already solved, I do not know whether the installation of python-pyudev or reinstalling xf86-input-libinput helped, in any case the problem no longer occurs.

Loading...