Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#67052 - [archiso] Arch Linux doesn't boot from the official image (USB, UEFI)

Attached to Project: Release Engineering
Opened by Yuri Kanivetsky (x-yuri) - Saturday, 20 June 2020, 08:43 GMT
Last edited by David Runge (dvzrv) - Friday, 31 July 2020, 08:33 GMT
Task Type Bug Report
Category Hardware Issues
Status Closed
Assigned To David Runge (dvzrv)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: It displays the menu: https://linuxhint.com/wp-content/uploads/2018/03/l.png I choose the first item, the menu disappears, and nothing happens.

The image was written to the USB drive with dd.

I made it work by removing the partitions, and adding a vfat one with label ARCH_202006. Then I copied the files from the iso image. This way it works.

I guess it has something to do with xorriso: https://gitlab.archlinux.org/archlinux/archiso/-/blob/01521adc/archiso/mkarchiso#L287-316

Is there anything I can check or confirm?

Additional info:
* archiso 44-2
* archlinux-2020.06.01-x86_64.iso
* libisoburn 1.5.2-2
* UEFI motherboard

Steps to reproduce:
* dd the official image to a USB drive and boot
This task depends upon

Closed by  David Runge (dvzrv)
Friday, 31 July 2020, 08:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with archiso >= 45
Comment by Yuri Kanivetsky (x-yuri) - Saturday, 20 June 2020, 10:40 GMT
I just tried to reproduce it (make it work by recreating the partition, and copying the files), and failed. But I've found another way: write the official image, but not let it run EFI/boot/bootx64.efi. Run EFI/boot/loader.efi. Which probably means that something is wrong with /usr/share/efitools/efi/PreLoader.efi:

https://gitlab.archlinux.org/archlinux/archiso/-/blob/2ce375cd/configs/releng/build.sh#L156

And it seems to be easy to build:

https://git.kernel.org/pub/scm/linux/kernel/git/jejb/efitools.git/tree/PreLoader.c?id=392836a46ce3c92b55dc88a1aebbcfdfc5dcddce

Could it possibly has something to do with disabled Secure Boot...
Comment by Yuri Kanivetsky (x-yuri) - Sunday, 21 June 2020, 08:09 GMT
Further testing revealed that the official image works sometimes. But loader.efi always works (it didn't fail so far). And not sure if relevant, but every boot starts with:

[ 0.81296] DMAR: [Firmware Bug]: No firmware reserved region can cover this
RMRR [0x000000008d800000-0x000000008fffffff], contact BIOS vendor for fixes
:: running early hook [udev]
Starting version 245.6-7-arch
...

I tried to add a couple of print statements to PreLoader.efi, but that didn't produce any tangible results.
Comment by nl6720 (nl6720) - Sunday, 21 June 2020, 10:21 GMT
PreLoader.efi in archiso is just a waste of space, so this issue could be "fixed" by  FS#59487  .
Comment by Yuri Kanivetsky (x-yuri) - Sunday, 21 June 2020, 13:07 GMT
Thanks, I posted a patch there. From what I can see with the patch it always works.

P.S. Just in case. A forum post with which it all started:

https://bbs.archlinux.org/viewtopic.php?pid=1911494
Comment by David Runge (dvzrv) - Saturday, 11 July 2020, 09:58 GMT
@x-yuri: Does this work with the 2020.07.01 image for you?
Comment by Yuri Kanivetsky (x-yuri) - Sunday, 12 July 2020, 00:58 GMT
@dvzrv yes

Loading...