Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67020 - [chromium] broken media playback with ffmpeg 4.3

Attached to Project: Arch Linux
Opened by Stefan Kain (stkain) - Tuesday, 16 June 2020, 09:08 GMT
Last edited by Evangelos Foutras (foutrelis) - Tuesday, 14 July 2020, 22:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Maxime Gauduin (Alucryd)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 15
Private No

Details

Hello,

after pacman -Syu
current chromium 83.0.4103.106-1
experiences a sigsegv e.g on youtube.
It seems to be caused by ffmpeg -1:4.3-1

Additional info:
* package version(s)
chromium 83.0.4103.106-1
ffmpeg -1:4.3-1

Steps to reproduce:
pacman -Syu.
in chromium, go to www.youtube.com, pick a video
--> chromium goes to "Snap!" page with sigsegv message.

Downgrading ffmpeg to 1:4.2.3-5
fixes the crash and video replay is possible again.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Tuesday, 14 July 2020, 22:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  chromium-84.0.4147.89-1, electron-9.1.0-3, electron5-5.0.13-7, electron6-6.1.9-7, electron7-7.1.14-7
Comment by Pete Alexandrou (ozmartian) - Tuesday, 16 June 2020, 09:26 GMT
FYI, this has been happening ever since the 4.3 ffmpeg dev branch was started. it's definitely ffmpeg breaking Chromium Media requests anywhere video or even audio needs to be played (even the official PushBullet extension crashes on browser start too), resulting in sigsegv. dmesg and core logs show core errors as per follows, each and everytime:

Media[23881]: segfault at c ip 000055de121a06ad sp 00007fde34eb2b00 error 6 in chromium[55de117b2000+769d000]
Code: 48 81 c4 18 02 00 00 5b 41 5c 41 5d 41 5e 41 5f 5d c3 e8 d6 d4 ca 06 cc cc cc cc cc cc 55 48 89 e5 41 56 53 49 89 f6 48 89 fb <c7> 46 0c 01 00 00 00 8b 0f 83 c1 ff 83 f9 0e 77 43 b8 02 50 01 00
audit: type=1701 audit(1592298876.302:154): auid=1000 uid=1000 gid=1000 ses=1 pid=23839 comm="Media" exe="/usr/lib/chromium/chromium" sig=11 res=1

It's not really an ArchLinux issue unless maybe there are some new or changed compile flags needed to keep latest ffmpeg release working with Chromium? I've spent some time trying to find info on this from other distros and ffmpeg on github but no one seems to be having issues or run into this. its a Linux breaker for me :-(
Comment by tonurics (Tonurics) - Tuesday, 16 June 2020, 09:30 GMT
I can confirm that downgrading ffmpeg also resolves #67018 [Chromium sigsegv on GMail].
Comment by Jens Keim (pepper-jk) - Tuesday, 16 June 2020, 10:02 GMT
This bug also effects electron apps, such as wire-desktop, riot-desktop.

Downgrading ffmpeg helped.
Comment by Evangelos Foutras (foutrelis) - Tuesday, 16 June 2020, 10:25 GMT
ffmpeg will be downgraded while we investigate the issue.
Comment by Arthur Borsboom (ArthurBorsboom) - Tuesday, 16 June 2020, 11:37 GMT
Google Calendar and Reddit crashes too (SIGSEGV), with dmesg reporting:

Media[3403]: segfault at 90 ip 000055ece8df8fb9 sp 00007fb4f7bed0e0 error 6 in chromium[55ece8419000+763e000]
Comment by Evangelos Foutras (foutrelis) - Tuesday, 16 June 2020, 18:06 GMT
Bisecting points to: https://github.com/FFmpeg/FFmpeg/commit/731c77589841

Rebuilding Chromium doesn't help, but reverting the above commit fixes it.
Comment by Evangelos Foutras (foutrelis) - Wednesday, 17 June 2020, 09:02 GMT
Chromium issue filed for this: https://crbug.com/1095962
Comment by Pete Alexandrou (ozmartian) - Wednesday, 17 June 2020, 22:29 GMT
you guys are wizards! nice work. can't believe this wasn't discovered earlier during ffmpeg's 4.3 branch development.
Comment by Robin Heinemeier (Sunner) - Sunday, 12 July 2020, 14:58 GMT
Any news on this? According to the linked Chromium issue this won't be fixed until version 86 (current stable is 83):

>This will be fixed when Chrome updates to FFmpeg 4.3 in M86.

>Distributions that are shipping Chromium using system libraries may apply the patch in #12 to work around the most severe issue, but note that Chromium is not (yet) compatible with FFmpeg 4.3 in other ways.
Comment by Evangelos Foutras (foutrelis) - Sunday, 12 July 2020, 15:02 GMT
I'm going to patch Chromium 84 (out in a couple of days) along with the various electron* packages. We should then be able to update ffmpeg.

Loading...