Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66977 - [linux] iwlwifi: probe of 0000:00:14.3 failed with error -22

Attached to Project: Arch Linux
Opened by Stefan (J4son) - Thursday, 11 June 2020, 17:37 GMT
Last edited by freswa (frederik) - Friday, 31 July 2020, 16:07 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Levente Polyak (anthraxx)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:

Module iwlwifi could not could not be loaded at 5.7.2. See attached error log. On 5.6.x there were no problems. I have attached the dmesg output on latest lts kernel for the iwlwifi module if this helps.

   iwllog (5.8 KiB)
   ltslog (1.5 KiB)
This task depends upon

Closed by  freswa (frederik)
Friday, 31 July 2020, 16:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with 5.7.11 as this patch was included: https://patchwork.kernel.org/patch/11662 083/
Comment by Peter Fern (pdf) - Friday, 12 June 2020, 01:08 GMT
Confirming the issue here, same stack trace, same wifi device.

I tested kernels 5.7.2.arch1-1 5.7.1.arch1-1 5.7.arch1-1 and all exhibit the same problem, downgrading to 5.6.15.arch1-1 allows iwlwifi to load as normal.
Comment by Erik Stein (eriks) - Friday, 12 June 2020, 13:41 GMT
Same issue, attaching dmesg log of PCI initializing attempt: echo 1 > /sys/bus/pci/devices/0000\:00\:14.3/remove && echo 1 > /sys/bus/pci/rescan
Comment by loqs (loqs) - Friday, 12 June 2020, 14:48 GMT Comment by Peter Fern (pdf) - Sunday, 28 June 2020, 11:39 GMT
Same result from 5.7.6.arch1-1
Comment by Stefan (J4son) - Sunday, 28 June 2020, 14:51 GMT
I tried with the mainline kernel (5.8-rc2) and the problem exists there too. I hope it will be fixed in 5.7.7 :/
Comment by Erik Stein (eriks) - Tuesday, 30 June 2020, 15:38 GMT
I don't have an issue any more with 5.7.4.arch1-1 and 5.7.6.arch1-1

00:14.3 Network controller: Intel Corporation Cannon Point-LP CNVi [Wireless-AC] (rev 11)
Kernel driver in use: iwlwifi

[ 4.857570] iwlwifi 0000:00:14.3: loaded firmware version 46.8902351f.0 9000-pu-b0-jf-b0-46.ucode op_mode iwlmvm
[ 4.857599] iwlwifi 0000:00:14.3: Direct firmware load for iwl-debug-yoyo.bin failed with error -2
...
[ 5.037511] iwlwifi 0000:00:14.3: Detected Intel(R) Wireless-AC 9560, REV=0x318
[ 5.085218] iwlwifi 0000:00:14.3: base HW address: ...
Comment by Stefan (J4son) - Tuesday, 30 June 2020, 18:46 GMT
I think you have a different wlan device. For me it is the "Killer Wireless AC 1550" which uses an intel chip and uses the iwlwifi kernel driver (https://support.killernetworking.com/knowledge-base/linux-support/)
Comment by Stefan (J4son) - Thursday, 02 July 2020, 10:12 GMT
A user added a patch in the bugreport @ kernel.org. Would it be possible to add this patch to the 5.7.7?

It is this patch: https://bugzilla.kernel.org/attachment.cgi?id=290037&action=diff
Comment by Stefan (J4son) - Friday, 03 July 2020, 13:47 GMT
I've compiled the iwlwifi module with this patch with kernel 5.7.7 and it works perfect. Hopefully the patch will be integrated in 5.7.8:

[ 21.604550] iwlwifi 0000:00:14.3: loaded firmware version 46.8902351f.0 9000-pu-b0-jf-b0-46.ucode op_mode iwlmvm
[ 21.959183] iwlwifi 0000:00:14.3: Detected Killer (R) Wireless-AC 1550i Wireless Network Adapter (9560NGW), REV=0x318
[ 22.008164] iwlwifi 0000:00:14.3: base HW address: 48:f1:7f:82:17:39
[ 22.220676] iwlwifi 0000:00:14.3 wlp0s20f3: renamed from wlan0
Comment by loqs (loqs) - Sunday, 12 July 2020, 16:15 GMT
Can you confirm the issue is fixed in linux 5.7.8.arch1-1 currently in testing?
Comment by Octavia Togami (octylFractal) - Tuesday, 14 July 2020, 05:42 GMT
Can confirm that for me, 5.7.8.zen2-1 which contains the same patch has restored my functionality:

[ 3.462715] iwlwifi 0000:00:14.3: loaded firmware version 46.8902351f.0 9000-pu-b0-jf-b0-46.ucode op_mode iwlmvm
[ 3.462731] iwlwifi 0000:00:14.3: Direct firmware load for iwl-debug-yoyo.bin failed with error -2
[ 3.805811] iwlwifi 0000:00:14.3: Detected Killer (R) Wireless-AC 1550i Wireless Network Adapter (9560NGW), REV=0x318
[ 3.858458] iwlwifi 0000:00:14.3: base HW address: a8:6d:aa:3c:22:74
Comment by Evzen Demcenko (lanconnected) - Thursday, 23 July 2020, 15:09 GMT
Broken in kernel 5.7.9 again.
Comment by Octavia Togami (octylFractal) - Thursday, 23 July 2020, 20:04 GMT
I cannot replicate:

$ uname -a
Linux Draconnet 5.7.9-arch1-1 #1 SMP PREEMPT Thu, 16 Jul 2020 19:34:49 +0000 x86_64 GNU/Linux

$ dmesg | grep iwlwifi
<omitted>
[ 3.822998] iwlwifi 0000:00:14.3: loaded firmware version 46.8902351f.0 9000-pu-b0-jf-b0-46.ucode op_mode iwlmvm
[ 3.823020] iwlwifi 0000:00:14.3: Direct firmware load for iwl-debug-yoyo.bin failed with error -2
[ 4.255421] iwlwifi 0000:00:14.3: Detected Killer (R) Wireless-AC 1550i Wireless Network Adapter (9560NGW), REV=0x318
[ 4.303736] iwlwifi 0000:00:14.3: base HW address: a8:6d:aa:3c:22:74

Perhaps a different bug affects you (Evzen)?
Comment by Peter Fern (pdf) - Thursday, 23 July 2020, 20:09 GMT
Also working fine here on 5.7.9-arch1-1
Comment by Evzen Demcenko (lanconnected) - Friday, 24 July 2020, 14:52 GMT
You are probably right and this is some other bug, but wireless card stopped working after update to 5.7.9
This is what i see in kernel log while using 5.7.9:
Jul 23 13:52:12 lenovo kernel: cfg80211: Loading compiled-in X.509 certificates for regulatory database
Jul 23 13:52:12 lenovo kernel: cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
Jul 23 13:52:12 lenovo kernel: platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
Jul 23 13:52:12 lenovo kernel: cfg80211: failed to load regulatory.db
Jul 23 13:52:12 lenovo kernel: Intel(R) Wireless WiFi driver for Linux
Jul 23 13:52:12 lenovo kernel: Copyright(c) 2003- 2015 Intel Corporation
Jul 23 13:52:13 lenovo kernel: iwlwifi: probe of 0000:00:14.3 failed with error -110
Jul 23 13:53:18 lenovo kernel: cfg80211: Loading compiled-in X.509 certificates for regulatory database
Jul 23 13:53:18 lenovo kernel: cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
Jul 23 13:53:18 lenovo kernel: platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
Jul 23 13:53:18 lenovo kernel: cfg80211: failed to load regulatory.db
Jul 23 13:53:18 lenovo kernel: Intel(R) Wireless WiFi driver for Linux
Jul 23 13:53:18 lenovo kernel: Copyright(c) 2003- 2015 Intel Corporation
Jul 23 13:53:18 lenovo kernel: iwlwifi: probe of 0000:00:14.3 failed with error -110

Kernel 5.7.8 works without issues, kernel log follows:
Jul 23 14:07:04 lenovo kernel: cfg80211: Loading compiled-in X.509 certificates for regulatory database
Jul 23 14:07:04 lenovo kernel: mei_me 0000:00:16.0: enabling device (0000 -> 0002)
Jul 23 14:07:04 lenovo kernel: cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
Jul 23 14:07:04 lenovo kernel: platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
Jul 23 14:07:04 lenovo kernel: cfg80211: failed to load regulatory.db
Jul 23 14:07:04 lenovo kernel: intel-lpss 0000:00:15.0: enabling device (0004 -> 0006)
Jul 23 14:07:04 lenovo kernel: idma64 idma64.0: Found Intel integrated DMA 64-bit
Jul 23 14:07:04 lenovo kernel: intel-lpss 0000:00:15.1: enabling device (0004 -> 0006)
Jul 23 14:07:04 lenovo kernel: idma64 idma64.1: Found Intel integrated DMA 64-bit
Jul 23 14:07:04 lenovo kernel: i2c_hid i2c-SYNACD3E:00: supply vdd not found, using dummy regulator
Jul 23 14:07:04 lenovo kernel: i2c_hid i2c-SYNACD3E:00: supply vddl not found, using dummy regulator
Jul 23 14:07:04 lenovo kernel: Adding 31406076k swap on /dev/nvme0n1p5. Priority:-2 extents:1 across:31406076k SSFS
Jul 23 14:07:04 lenovo kernel: i801_smbus 0000:00:1f.4: SPD Write Disable is set
Jul 23 14:07:04 lenovo kernel: i801_smbus 0000:00:1f.4: SMBus using PCI interrupt
Jul 23 14:07:04 lenovo kernel: input: PC Speaker as /devices/platform/pcspkr/input/input8
Jul 23 14:07:04 lenovo kernel: Intel(R) Wireless WiFi driver for Linux
Jul 23 14:07:04 lenovo kernel: Copyright(c) 2003- 2015 Intel Corporation
Jul 23 14:07:04 lenovo kernel: iwlwifi 0000:00:14.3: api flags index 2 larger than supported by driver
Jul 23 14:07:04 lenovo kernel: iwlwifi 0000:00:14.3: TLV_FW_FSEQ_VERSION: FSEQ Version: 65.3.35.22
Jul 23 14:07:04 lenovo kernel: iwlwifi 0000:00:14.3: Found debug destination: EXTERNAL_DRAM
Jul 23 14:07:04 lenovo kernel: iwlwifi 0000:00:14.3: Found debug configuration: 0
Jul 23 14:07:04 lenovo kernel: iwlwifi 0000:00:14.3: loaded firmware version 53.c31ac674.0 QuZ-a0-hr-b0-53.ucode op_mode iwlmvm
Jul 23 14:07:04 lenovo kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwl-debug-yoyo.bin failed with error -2
Comment by Stefan (J4son) - Thursday, 30 July 2020, 15:00 GMT
Fixed with 5.7.11 cause this patch was merged: https://patchwork.kernel.org/patch/11662083/
Comment by loqs (loqs) - Thursday, 30 July 2020, 15:22 GMT
@J4son the Arch linux package has applied that patch since 5.7.8-arch1 [1].
lanconnected stated it was broken with 5.7.9 [2]. 5.7.11-arch1, Arch no longer needed to apply the patch as it was applied upstream.

[1] https://git.archlinux.org/linux.git/commit/?h=v5.7.8-arch1&id=2fadccbdd143a95db9ba06110261142c9bb2acbd
[2] https://bugs.archlinux.org/task/66977#comment191181
Comment by Stefan (J4son) - Thursday, 30 July 2020, 16:31 GMT
Oh i am really sorry! I did not see the patch was included. I have compiled the iwlwifi module by my own since the patch was released. The first time i did not compile the iwlwifi module was 5.7.11. Sorry for that!

@lanconnected:

What is the id of your wireless card?

lspci -v -nn:

00:14.3 Network controller [0280]: Intel Corporation Wireless-AC 9560 [Jefferson Peak] [8086:a370] (rev 10)
Subsystem: Bigfoot Networks, Inc. Device [1a56:1552]
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at a6418000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi

Loading...