Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66948 - [gnome-control-center] Remove "Bluetooth" from gnome-user-share optdepend description

Attached to Project: Arch Linux
Opened by Bastien Traverse (Neitsab) - Monday, 08 June 2020, 23:29 GMT
Last edited by Jan Alexander Steffens (heftig) - Monday, 08 June 2020, 23:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

gnome-control-center PKGBUILD details gnome-user-share optdepend as providing "Bluetooth and WebDAV file sharing"[1]. However,

1) gnome-user-share upstream doesn't make any mention of Bluetooth[2],
2) the package itself doesn't provide any file relating to bluetooth nor depends on a bluetooth-related package[3],
3) upstream NEWS file contains an item for version 3.14.2 saying "Remove ObexPush support, it's now available directly in the gnome-bluetooth Settings widget"[4] and version 3.14 "Don't talk of "sharing over Bluetooth" since ObexFTP support was removed"[5].

So as not to lead users thinking this package is required for bluetooth sharing support, I'd suggest simply removing the mention of Bluetooth in the optdepend description.

Thanks

[1] https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/gnome-control-center#n19
[2] https://gitlab.gnome.org/GNOME/gnome-user-share
[3] https://www.archlinux.org/packages/extra/x86_64/gnome-user-share/files/
[4] https://gitlab.gnome.org/GNOME/gnome-user-share/-/blob/master/NEWS#L43-44
[5] https://gitlab.gnome.org/GNOME/gnome-user-share/-/blob/master/NEWS#L53
Additional info:
* package version(s): 3.36.3-1

Steps to reproduce:
- install gnome group
- remove gnome-user-share
- try to share a file via Bluetooth
- should work all right (though bluetooth itself is pretty finicky)
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Monday, 08 June 2020, 23:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in trunk; thanks.

Loading...