Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66943 - [vlc] cannot accelerate some mpeg avi videos

Attached to Project: Community Packages
Opened by Andrea Amorosi (AndreaA) - Monday, 08 June 2020, 16:17 GMT
Last edited by freswa (frederik) - Monday, 08 June 2020, 16:45 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
On my laptop vlc cannot accelerate hardware some avi mpeg videos that are played in jerky mode.
When this problem happens I get the following output on the console from which I've launched vlc:

VLC media player 3.0.10 Vetinari (revision 3.0.10-0-g7f145afa84)
[0000558de8dea5b0] main libvlc: Esecuzione di vlc con l'interfaccia predefinita. Usa 'cvlc' per utilizzare vlc senza interfaccia.
[QtOIIO] Plugin Initialized
[00007f59380079e0] avcodec decoder: Using NVIDIA VDPAU Driver Shared Library 440.82 Wed Apr 1 19:39:06 UTC 2020 for hardware decoding
[mpeg4 @ 0x7f5938cad380] Failed setup for format vdpau: hwaccel initialisation returned error.
[00007f59380079e0] avcodec decoder error: existing hardware acceleration cannot be reused
[0000558de8eb2430] main playlist: end of playlist, exiting
QObject::~QObject: Timers cannot be stopped from another thread

In the past (months or a couple of years ago) the same files played correctly with vlc.

My laptop is an asus n752vx with i7-6700hq, 16GB RAM, nvidia 950M with proprietary drivers set up in order to always use the discrete card instead of the intel one and with prime enabled using nvidia-drm.modeset=1 and this is mine xorg.conf:

Section "Module"
Load "modesetting"
EndSection

Section "Device"
Identifier "nvidia"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "AllowEmptyInitialConfiguration"
EndSection

Additional info:
* package version(s) 3.0.10

Steps to reproduce: try to play some specific .avi mpeg coded files which previously used to work
This task depends upon

Closed by  freswa (frederik)
Monday, 08 June 2020, 16:45 GMT
Reason for closing:  Not a bug
Additional comments about closing:  This is not a packaging bug. Please use the forum, the IRC or the ML to ask for support.
Thank you
Comment by Andrea Amorosi (AndreaA) - Monday, 08 June 2020, 16:22 GMT
I cannot share those files, but if needed I can try to execute all the tests you need to identify from where the issue arises.

Loading...