Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66906 - [matrix-synapse] mismatching version of python-prometheus_client

Attached to Project: Community Packages
Opened by Luca Weiss (z3ntu) - Friday, 05 June 2020, 06:43 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 05 June 2020, 12:26 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When starting synapse 1.13.0 after a system update just now I get the following error:

ERROR:root:Needed prometheus_client>=0.0.18,<0.8.0, got prometheus-client==0.8.0

Additional info:
* matrix-synapse 1.13.0-1

Steps to reproduce:
* Update system and restart synapse
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 05 June 2020, 12:26 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#66901 
Comment by Luca Weiss (z3ntu) - Friday, 05 June 2020, 06:50 GMT
I've changed /usr/lib/python3.8/site-packages/synapse/python_dependencies.py to say <0.9.0 instead of <0.8.0 and synapse starts up correctly. I'm not using any prometheus functionality though (as far as I know).

Loading...