Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66901 - [matrix-synapse] --generate-config fails. missing requirements

Attached to Project: Community Packages
Opened by Matthias Lisin (matthias.lisin) - Thursday, 04 June 2020, 18:39 GMT
Last edited by Johannes Löthberg (demize) - Wednesday, 10 June 2020, 14:52 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Johannes Löthberg (demize)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
The initial step to generate configuration fails due to the recent python-prometheus_client update:

Message:
ERROR:root:Needed prometheus_client>=0.0.18,<0.8.0, got prometheus-client==0.8.0
Missing Requirements: 'prometheus_client>=0.0.18,<0.8.0'
To install run:
pip install --upgrade --force 'prometheus_client>=0.0.18,<0.8.0'

Additional info:
* Versions: 1.13.0-1 / 1.14.0-1 (community-testing)

Steps to reproduce:
1. Run the command printed by the post_install hook:

sudo -u synapse python -m synapse.app.homeserver \
--server-name my.domain.name \
--config-path /etc/synapse/homeserver.yaml \
--generate-config \
--report-stats=yes
This task depends upon

Closed by  Johannes Löthberg (demize)
Wednesday, 10 June 2020, 14:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.14.0-2

Loading...