Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66897 - [geoip-database] IPv4-mapped addresses in GeoIPv6.dat

Attached to Project: Arch Linux
Opened by Miha Verlic (fluke571) - Thursday, 04 June 2020, 12:35 GMT
Last edited by Evangelos Foutras (foutrelis) - Tuesday, 12 April 2022, 04:07 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

geoip-database 20200519-1 does not contain IPv4-mapped addresses in GeoIPv6.dat anymore. This breaks compatibility with ngx_http_geoip_module and possibly others, where you could simply use GeoIPv6.dat to map addresses to countries since you can't specify database per protocol. Is there any chance to add IPv4 mapped addresses to GeoIPv6.dat?

Additional info:
geoip-database 20200519-1

Steps to reproduce:

before (geoip-database 20180403-1):
~]# geoiplookup6 -f /usr/share/GeoIP/GeoIPv6.dat ::ffff:195.66.1.4
GeoIP Country V6 Edition: DE, Germany

now:
~]# geoiplookup6 -f /usr/share/GeoIP/GeoIPv6.dat ::ffff:195.66.1.4
GeoIP Country V6 Edition: IP Address not found
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Tuesday, 12 April 2022, 04:07 GMT
Reason for closing:  Upstream
Additional comments about closing:  Doesn't seem like this will be fixed; consider switching to libmaxminddb.
Comment by Evangelos Foutras (foutrelis) - Thursday, 04 June 2020, 17:39 GMT
Looks like an upstream issue exists for this at https://github.com/sherpya/geolite2legacy/issues/12

Loading...