Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#66871 - [archiso] Assumed dependency on mkinitcpio hooks

Attached to Project: Release Engineering
Opened by Xuanrui Qi (xuanrui) - Wednesday, 03 June 2020, 01:19 GMT
Last edited by David Runge (dvzrv) - Wednesday, 01 July 2020, 06:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
David Runge (dvzrv)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The archiso scripts seem to have an assumed dependency on `mkinitcpio` hooks being run. For `dracut` users, `mkinitcpio` hooks are usually disabled and this results in iso unbuildable.

Steps to reproduce:
* install dracut and disable mkinitcpio hooks, replace with dracut hooks
* follow instructions to build archiso on the wiki
* get an error message due to `vmlinuz-linux` not found, can't cotinue.
This task depends upon

Closed by  David Runge (dvzrv)
Wednesday, 01 July 2020, 06:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with v45
Comment by David Runge (dvzrv) - Thursday, 11 June 2020, 10:51 GMT
@xuanrui: Thanks for the report.

Yes, as dracut and mkinitcpio both provide initramfs we have now decoupled our hard requirement on mkinitcpio.
This is not yet reflected in archiso and I guess I will have to add a specific dependency on mkinitcpio for the package and project.

Loading...