Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#66835 - [archiso] build fails after generating invalid directory names on ntfs

Attached to Project: Release Engineering
Opened by Shivanand (shivanandvp) - Saturday, 30 May 2020, 06:07 GMT
Last edited by David Runge (dvzrv) - Saturday, 30 May 2020, 10:38 GMT
Task Type Bug Report
Category ArchISO
Status Closed
Assigned To David Runge (dvzrv)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: Trying to build an Arch Linux ISO using 'archiso' with the 'releng' profile tries to create directories with invalid names before failing.

Additional info:
* package version(s): archiso 43-2
* config and/or log files etc: Terminal dump attached
* link to upstream bug report, if any: N/A

Steps to reproduce:
(Run as root as per the Wiki: https://wiki.archlinux.org/index.php/Archiso)
# cp -r /usr/share/archiso/configs/releng/ archlive
# cd archlive
# ./build.sh -v
This task depends upon

Closed by  David Runge (dvzrv)
Saturday, 30 May 2020, 10:38 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Don't use NTFS for creating an image using archiso
Comment by Frederic Bezies (fredbezies) - Saturday, 30 May 2020, 06:58 GMT
Just try to create a directory in your own space.

I've done this a lot of time, and it worked every single time.

First line (root is not really needed)

cp -r /usr/share/archiso/configs/releng/ ~archlive
cd ~archlive
sudo ./build.sh -v

Remember that ~ is a shortcut for /home/YourUsername/
Comment by Shivanand (shivanandvp) - Saturday, 30 May 2020, 07:07 GMT
A reddit member of r/archlinux/ helped figure it out (https://www.reddit.com/r/archlinux/comments/gt9gjo/archiso_is_nonfunctional/).

It seems like archiso does not work on NTFS (although I think that it did in 2018, since I used the same path for building ISOs). Is there a plan to make archiso compatible with NTFS?
Comment by David Runge (dvzrv) - Saturday, 30 May 2020, 10:37 GMT
@shivanandvp: Please use a sane non-proprietary filesystem!

NTFS has issues with long path names, has a fundamentally different way of dealing with permissions and depending on whether you dual boot with windows it might do weird other things to your file and folder names, too.

Loading...