Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66834 - [blender] fails to launch resulting in SIGILL

Attached to Project: Community Packages
Opened by Igor (igvalor) - Saturday, 30 May 2020, 02:47 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 31 May 2020, 14:08 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Filipe LaĆ­ns (FFY00)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When I'm trying to launch Blender it fails with the message "illegal hardware instruction" (launched from command line).

Additional info:
* Blender 2.82.a-6
* Blender downloaded from the official site (which is statically linked) launches without problems. Which can mean that the problem is (maybe) not in Blender itself, but in some dynamic lib it uses. Tried to use ltrace tool but it showed nothing, just the same message about illegal HW instruction.

Steps to reproduce:
Launch Blender from terminal.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 31 May 2020, 14:08 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#66779 
Comment by Igor (igvalor) - Saturday, 30 May 2020, 02:50 GMT
Oh, I forgot! blender package is in community category, not extra.
Comment by Doug Newgard (Scimmia) - Saturday, 30 May 2020, 14:06 GMT
With what processor? And what's the exact error?
Comment by Igor (igvalor) - Sunday, 31 May 2020, 03:21 GMT
The hardware is:
CPU: Intel Core 2 Quad 6600
GPU: Nvidia GT630
RAM: 6GB

P.S. Don't tell me, that Blender should not work on such a piece of cr...p!
Comment by Igor (igvalor) - Sunday, 31 May 2020, 03:23 GMT
@Scimmia The exact error is:
[1] <PID> illegal hardware instruction blender

Loading...