Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66818 - [mesa] 20.1.0-2 causes Xorg to crash when viewing some websites on Firefox

Attached to Project: Arch Linux
Opened by Chih-Hsuan Yen (yan12125) - Friday, 29 May 2020, 05:34 GMT
Last edited by freswa (frederik) - Sunday, 31 May 2020, 15:40 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Laurent Carlier (lordheavy)
Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
With up-to-date Arch Linux and testing repos enabled, surfing some websites on Firefox causes Xorg to crash. An example website is https://store.kde.org/p/1327319. If I downgraded mesa to 20.1.0-1, everything seems fine.

Additional info:

Crash log from ~/.local/share/xorg/Xorg.0.log

[132368.267] (EE) Backtrace:
[132368.267] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x4d) [0x558a0ef7976d]
[132368.267] (EE) 1: /usr/lib/Xorg (0x558a0eec6000+0xa9cd8) [0x558a0ef6fcd8]
[132368.267] (EE) 2: /usr/lib/libc.so.6 (0x7fc25518d000+0x3c3e0) [0x7fc2551c93e0]
[132368.267] (EE) 3: /usr/lib/dri/i965_dri.so (0x7fc253229000+0x149247) [0x7fc253372247]
[132368.267] (EE) 4: /usr/lib/libgbm.so.1 (0x7fc25535b000+0x5991) [0x7fc255360991]
[132368.267] (EE) 5: /usr/lib/xorg/modules/libglamoregl.so (glamor_egl_fds_from_pixmap+0x5b) [0x7fc25420f61b]
[132368.267] (EE) 6: /usr/lib/Xorg (0x558a0eec6000+0x9efd7) [0x558a0ef64fd7]
[132368.267] (EE) 7: /usr/lib/Xorg (0x558a0eec6000+0x39068) [0x558a0eeff068]
[132368.267] (EE) 8: /usr/lib/libc.so.6 (__libc_start_main+0xf2) [0x7fc2551b4002]
[132368.267] (EE) 9: /usr/lib/Xorg (_start+0x2e) [0x558a0eeff39e]
[132368.267] (EE)
[132368.267] (EE) Segmentation fault at address 0x130

Full Xorg.0.log is attached below.

Environment: Intel HD Graphics 4600 on i7-4770. I also have an ancient GeForce GTS 450 but I don't think it's enabled.

Steps to reproduce:
Put `firefox https://store.kde.org/p/1327319` to ~/.xinitrc and run startx.

I use SDDM+LXQt+kwin, so I use xinit to make sure the bug is not from qt 5.15.
This task depends upon

Closed by  freswa (frederik)
Sunday, 31 May 2020, 15:40 GMT
Reason for closing:  Fixed
Comment by Evangelos Foutras (foutrelis) - Friday, 29 May 2020, 21:36 GMT
mpv in fullscreen triggers a Xorg crash as well.

Edit: Commented upstream with a sparse backtrace: https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4861#note_516720
Comment by Vladimir (_v_l) - Saturday, 30 May 2020, 03:05 GMT
Same here on two hosts but I see segfault earilier (X crashes immideately I enter password in lightdm) because I use picom as compositor. Meanwhile skylake processor works fine:
Crash: Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz
Intel(R) Pentium(R) CPU B960 @ 2.20GHz
Fine: Intel(R) Core(TM) i5-7400 CPU @ 3.00GHz

Seems that this affects only old Intel processors (I don't have any AMD system at hand).
Comment by Chih-Hsuan Yen (yan12125) - Sunday, 31 May 2020, 06:45 GMT
Problematic patches are removed in 20.1.0-4 [1]. The reported issue (Xorg crashes) is resolved and this issue can be closed.

[1] https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/mesa&id=628815b38af6fedb87bb443530135a688fd1f1fe

Loading...