Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#66816 - Plasma session can't be launched after upgrading Qt to 5.15.0

Attached to Project: Arch Linux
Opened by Igor (igvalor) - Friday, 29 May 2020, 03:38 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 02 June 2020, 08:10 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


Plasma session fails to start after upgrading Qt to 5.15.0.
Also under Cinnamon when I launch Dolphin file manager two SEGFAULT error notifications popup (see attached screenshots). The same error popups are shown when I'm trying to launch Plasma session from SDDM.

Steps to reproduce:
In SDDM choose session "Plasma" and login.
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 02 June 2020, 08:10 GMT
Reason for closing:  None
Additional comments about closing:  Ask for reopen if you can reproduce with a *new* user
Comment by Antonio Rojas (arojas) - Friday, 29 May 2020, 06:18 GMT
which Qt style are you using?
Comment by Igor (igvalor) - Saturday, 30 May 2020, 02:32 GMT
Comment by Igor (igvalor) - Saturday, 30 May 2020, 02:36 GMT
Tried to change to Breeze, Oxygen - same error popups (when launching Dolphin under Cinnamon for example). Which means that it has nothing to do with Qt styles.
Comment by Alisson Lauffer (alissonlauffer) - Saturday, 30 May 2020, 02:45 GMT
Krita also segfaults when using the Kvantum style, but when changing Qt style from Kvantum to fusion (With QT_QPA_PLATFORMTHEME=fusion), the application launches normally.
Comment by Antonio Rojas (arojas) - Saturday, 30 May 2020, 07:19 GMT
@igvalor How are you changing the style in cinnamon? please test (a) uninstalling kvantum completely and (b) with a clean user.

@alissonlauffer "QT_QPA_PLATFORMTHEME=fusion" shouldn't do anything, fusion is not a platform theme but a style. Also, krita hardcodes the fusion style already. Wnat is the output of "env | grep QT"?
Comment by Igor (igvalor) - Sunday, 31 May 2020, 03:15 GMT
Added fresh user. Problem stays.
Removed kvantum. Problem stays.
User and Kvantum have nothing to do with this library incompatibility. It looks like Plasma and KDE stuff must be rebuilt against the new version of Qt.
Comment by Antonio Rojas (arojas) - Sunday, 31 May 2020, 10:41 GMT
If that were the case this would affect everybody, not just you. Everything that needs a rebuild has been rebuilt already. Please run the attached binary with the new user and post the output. I attach the source code too in case you don't trust running random binaries.

Comment by Igor (igvalor) - Monday, 01 June 2020, 10:23 GMT
The program u attached said:

qt5ct: using qt5ct plugin
style: "qt5ct-style"
palette: QPalette(resolve=0x1dff7f,WindowText:[Active:0xffd4d5d8,Disabled:0xff919191,Inactive:0xffd4d5d8],Button:[Active:0xff414654,Disabled:0xff414654,Inactive:0xff414654],Light:[Active:0xff5f677f,Disabled:0xff5f677f,Inactive:0xff5f677f],Midlight:[Active:0xff313131,Disabled:0xff313131,Inactive:0xff313131],Dark:[Active:0xff000000,Disabled:0xff000000,Inactive:0xff000000],Mid:[Active:0xff191919,Disabled:0xff191919,Inactive:0xff191919],Text:[Active:0xffd6d7da,Disabled:0xff919191,Inactive:0xffd6d7da],ButtonText:[Active:0xffd4d4d4,Disabled:0xff919191,Inactive:0xffd4d4d4],Base:[Active:0xff404552,Disabled:0xff404552,Inactive:0xff404552],Window:[Active:0xff383c4a,Disabled:0xff383c4a,Inactive:0xff383c4a],Shadow:[Active:0xff000000,Disabled:0xff000000,Inactive:0xff000000],Highlight:[Active:0xff5294e2,Disabled:0xff5294e2,Inactive:0xff5194e1],HighlightedText:[Active:0xffffffff,Disabled:0xffffffff,Inactive:0xffffffff],Link:[Active:0xff009dff,Disabled:0xff009dff,Inactive:0xff009dff],LinkVisited:[Active:0xff9e4fff,Disabled:0xff9e4fff,Inactive:0xff9e4fff],AlternateBase:[Active:0xff3c434f,Disabled:0xff3c434f,Inactive:0xff3c434f],ToolTipBase:[Active:0xff000000,Disabled:0xff000000,Inactive:0xff000000],ToolTipText:[Active:0xffeefcff,Disabled:0xffeefcff,Inactive:0xffeefcff],PlaceholderText:[Active:0xffa0a3a9,Disabled:0xffa0a3a9,Inactive:0xffa0a3a9])
platform: "xcb"
platform themes: ("gtk3", "gnome", "generic")
Comment by Antonio Rojas (arojas) - Monday, 01 June 2020, 10:28 GMT
Please post your .config/qt5ct/qt5ct.conf
Comment by Igor (igvalor) - Monday, 01 June 2020, 12:42 GMT
Comment by Igor (igvalor) - Monday, 01 June 2020, 12:49 GMT
I disabled all Kvantum stuff, and kglobalaccel5 and klauncher crash popups disappeared. I even can launch Plasma session again.
But other trouble arouse. See attachment.
Comment by Igor (igvalor) - Monday, 01 June 2020, 12:55 GMT
Forgot. Here is another one
Comment by Antonio Rojas (arojas) - Monday, 01 June 2020, 12:56 GMT
What's the output of 'env | grep QT'?
Comment by Igor (igvalor) - Monday, 01 June 2020, 13:04 GMT

Comment by Antonio Rojas (arojas) - Monday, 01 June 2020, 13:07 GMT
Please test qt5ct 0.41-4
Comment by Igor (igvalor) - Monday, 01 June 2020, 14:36 GMT
updated qt5ct to 0.41-4. Nothing changed. Segmentation faults are still there (powerdevil and kdenit5). And KDE starts slower.
Comment by Igor (igvalor) - Monday, 01 June 2020, 15:00 GMT
I moved almost all KDE and Plasma stuff from ~/.config dir to a temporary dir. I thouhgt that Plasma should start from scratch. But everything returned to the situation I initially reported in this issue.
Comment by Antonio Rojas (arojas) - Monday, 01 June 2020, 15:12 GMT
Have you actually tested with a clean user like I asked you? Because I don't see how QT_QPA_PLATFORMTHEME can be set to qt5ct in a new, blank user
Comment by Igor (igvalor) - Monday, 01 June 2020, 16:11 GMT
Found the culprit!!!
Removed qt5ct package and KDE works like charm!