Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66771 - [audacity] selecting menu item View>Track Size>Fit to Height triggers uncaught crash

Attached to Project: Community Packages
Opened by James Carpenter (jbcx01) - Sunday, 24 May 2020, 23:53 GMT
Last edited by David Runge (dvzrv) - Wednesday, 27 May 2020, 21:46 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

The Audacity 2.4.1-3 package seems address the issue with Nyquist plug-in support not working, but I'm still seeing a crash that I first saw in 2.4.0.

When attempting to resize the height of the tracks by selecting View > Track Size > Fit to Height, the app does nothing for a second and then just dies. This crash is not caught by the usual Audacity exception mechanism that puts up a dialog telling the user a problem occurred and the app cannot continue running. Hence I've not been able to locate any logs with info on this crash, although normally it would be easy, since the dialog tells you where a crash log was created.

When I brought this up on the audacityteam.org forums, Steve replied: "This is a known issue that occurs in the builds that use the old autotools build chain. It does not occur if Audacity is built with cmake. The build instructions included in the source code say to use cmake."

So this appears to be an issue with building the Arch package. Thought it might be a useful test when switching to cmake. This particular one is killing me, because I use Fit to Height frequently when working in Audacity.


Additional info:

* package version(s): 2.4.1-3
* config and/or log files etc.: have config files if needed, but unsure where to find crash information
* discussion on Audacity forum is here: https://forum.audacityteam.org/viewtopic.php?f=48&t=110960&start=10
* First time filing an issue here - please let me know if this is done incorrectly.

Steps to reproduce:

1. Create a track to work with (Generate > Tone, for example) or open an audio file.
2) Select Track Size > Fit to Height from the View menu.
3) App crashes without displaying the usual crash dialog.
This task depends upon

Closed by  David Runge (dvzrv)
Wednesday, 27 May 2020, 21:46 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with audacity 1:2.4.1-4
Comment by David Runge (dvzrv) - Monday, 25 May 2020, 18:33 GMT
@jbcx01: Thanks for the report.

I have opened an upstream ticket about this: https://github.com/audacity/audacity/issues/538
Feel free to also follow up on things there.

Unfortunately there are still a bunch of problems preventing the use of the cmake based build system and this will be a massive time sink for me...
Comment by David Runge (dvzrv) - Wednesday, 27 May 2020, 21:44 GMT
Although this might only prove as an intermediate fix (as there are seemingly larger underlying problems at hand), I will apply this (trivial) fix [1] in a new pkgrel.

[1] https://github.com/audacity/audacity/pull/545/commits/d7e769040b508aaf15ce7b51cc1a565d41cdb079

Loading...