Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66758 - [xorg-server] early start of xorg-server crash when not using early KMS

Attached to Project: Arch Linux
Opened by Max Gautier (VannTen) - Saturday, 23 May 2020, 18:31 GMT
Last edited by freswa (frederik) - Sunday, 24 May 2020, 01:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:

Using the aur packages https://aur.archlinux.org/packages/xlogin-git/ led me to observe a weird behaviour of X
When using it normally, the expected result is to boot into the DE specified in .xinitrc
(Relevant wiki page : https://wiki.archlinux.org/index.php/Systemd/User#Automatic_login_into_Xorg_without_display_manager)

However, this does not work. The X server aborts, and I'm dumped on vt1, where i can login, then start the xlogin@user service, which then works.

The solution suggested on the last post here (https://bbs.archlinux.org/viewtopic.php?id=207631), that is, using early KMS start, works. (https://wiki.archlinux.org/index.php/kernel_mode_setting#Early_KMS_start)

Attached :
Xorg.0.log (with early KMS)
Xorg.0.log.old (without early KMS)


Steps to reproduce:

- install xlogin-git from AUR
- enable xlogin@username
- reboot (X crash when booting)
- log into the vt
- run as root "systemctl start xlogin@username" (X start and the DE works)
- modify the mkinitcpio.conf addings "nouveau" in the MODULES section
- regenerate the initramfs
- reboot (Works like a charm).
This task depends upon

Loading...