Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66749 - Mime Database is broken in Archlinux. The issue has roots both in upstream and downstream.

Attached to Project: Arch Linux
Opened by Leo Dazz (leodazz) - Saturday, 23 May 2020, 06:06 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 23 May 2020, 14:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Downstream Related: Every time pacman tries to update mime database, Warning about files not found is displayed. Actually, I think update-mime-database utility is looking for mime files in [ "/usr/share/mime/packages" ] only. As a result other directories [ sub-directories under "/usr/share/mime" ] are ignored. When I created symlinks from those sub-directories to the [ "/usr/share/mime/packages" ] directories, the issue is partially resolved.
Upstream Related: Packages don't follow updated mime database specs. Almost all mime files in the above directories have a root element [ "<mime-type>" ] which is outdated as you know. When I edited these files and replaced the outdated element with [ "<mime-info>" ], the issue is resolved. Everything is updated normally.


Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce: Simply run update-mime-database or let the pacman do it. All the screen is flooded with warnings related to mime files not found and wrong root element in mime files.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 23 May 2020, 14:53 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Use IRC, the forums, or the mailing lists for support.
Comment by Doug Newgard (Scimmia) - Saturday, 23 May 2020, 14:29 GMT
I can't reproduce, I have no warnings and update-mime-database works just fine.
Comment by Doug Newgard (Scimmia) - Saturday, 23 May 2020, 14:35 GMT
How do you have that many files in /usr/share/packages/? Something is seriously wrong with your system.

Loading...