Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66746 - [networkmanager] move out of gnome group?

Attached to Project: Arch Linux
Opened by hexchain (hexchain) - Friday, 22 May 2020, 20:58 GMT
Last edited by Jan de Groot (JGC) - Monday, 25 May 2020, 10:12 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
In an attempt at removing GNOME from my system I almost accidentally removed NetworkManager. It was added to the "gnome" group probably because of  FS#53496 , but to me the reason behind was probably only "it used to come with GNOME but not anymore" three years ago. Also, being a GNOME project really does not mean much, as there are other GNOME projects that are not in the "gnome" group, such as geary and shotwell.

NM does not depend on GNOME, it is equally useful on other DEs. And GNOME can just run perfectly without NM. So, I don't think it should be part of the "gnome" group.
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 25 May 2020, 10:12 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Saturday, 23 May 2020, 22:28 GMT
NetworkManager is part of core-deps upstream, so upstream has intended GNOME to run with NetworkManager.
We split nm-connection-editor into a standalone package so NetworkManager becomes optional, but that shouldn't move NM out of the gnome group by default.
Comment by Jan Alexander Steffens (heftig) - Sunday, 24 May 2020, 00:15 GMT
We want NM to be installed by default without necessarily being a dependency of another gnome package.

Loading...