Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#66745 - [apm] fails to search/install new packages

Attached to Project: Community Packages
Opened by Till (tillyboy) - Friday, 22 May 2020, 17:09 GMT
Last edited by freswa (frederik) - Saturday, 23 May 2020, 17:38 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Nicola Squartini (tensor5)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


apm fails to search/install new packages. Error is reproducible after reinstalling apm/atom/npm and trying npm rebuild -g. Is fixed when installing atom-editor-bin from AUR. I have also noticed a lot of atom bugs lately, not sure if those are associated, but since this issue is explicitly about apm, I would say it isn't.

Additional info:
* working versions (AUR):
* atom: 1.47.0
* apm: 2.4.5
* broken versions (Community):
* atom: 1.46.0
* apm: 2.5.0-1
* reproduces these issues:

Steps to reproduce:
1. Install atom+apm (from the community repos)
2. Try to install any atom package.

Possibly related:
This task depends upon

Comment by Till (tillyboy) - Friday, 22 May 2020, 17:09 GMT
I am stupid, can I somehow edit the title?
Comment by Nicola Squartini (tensor5) - Wednesday, 10 June 2020, 01:01 GMT
Can you be more specific? Which package fails to install?
Comment by Till (tillyboy) - Wednesday, 10 June 2020, 20:33 GMT
Several, I tried atom-latex, linter, linter-spell and linter-spell-latex. All failed. As I said I currently run the AUR version. Did you try the Community build without error? Are your version of apm and atom the same as the ones specified above? Just checked with pacman, community is at 1.47 now, so the issue might have already been fixed.
Comment by Nicola Squartini (tensor5) - Thursday, 11 June 2020, 00:14 GMT
apm is now at version 2.5.0. Try that.
Comment by Ismael Bejarano (ismael) - Thursday, 11 June 2020, 16:58 GMT
It seems that an upgrade to node break a dependency of apm.

A fresh install of atom going to Edit/Preferences/Install create the attached trace.
Comment by Nicola Squartini (tensor5) - Friday, 12 June 2020, 00:38 GMT
Are you using nodejs-lts? Try nodejs 14.
Comment by Ismael Bejarano (ismael) - Friday, 12 June 2020, 04:16 GMT
Installing nodejs (14.3.0-1) fixed the problem of installing packages in atom.
Comment by Till (tillyboy) - Friday, 12 June 2020, 07:42 GMT
> Are you using nodejs-lts? Try nodejs 14.

Aha! Works for me as well. I didn't even know I was running the LTS version, ty for the hint.
Comment by Antonio Fernandez (silveste) - Thursday, 21 January 2021, 02:32 GMT
I also have the same issue using:
*apm 2.6.1-1
*atom 1.54.0-1
*nodejs: 14.15.4-1
*nvm: 0.37.2-1 (nvm ls shows that node 14.15.0 is installed)

When I run apm in the console I get the following trace:
$apm help
return process.dlopen(module, path.toNamespacedPath(filename));

Error: The module '/usr/lib/node_modules/atom-package-manager/node_modules/git-utils/build/Release/git.node'
was compiled against a different Node.js version using
NODE_MODULE_VERSION 88. This version of Node.js requires
NODE_MODULE_VERSION 83. Please try re-compiling or re-installing
the module (for instance, using `npm rebuild` or `npm install`).
at Object.Module._extensions..node (internal/modules/cjs/loader.js:1122:18)
at Module.load (internal/modules/cjs/loader.js:928:32)
at Function.Module._load (internal/modules/cjs/loader.js:769:14)
at Module.require (internal/modules/cjs/loader.js:952:19)
at require (internal/modules/cjs/helpers.js:88:18)
at Object.<anonymous> (/usr/lib/node_modules/atom-package-manager/node_modules/git-utils/src/git.js:3:22)
at Module._compile (internal/modules/cjs/loader.js:1063:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:1092:10)
at Module.load (internal/modules/cjs/loader.js:928:32)
at Function.Module._load (internal/modules/cjs/loader.js:769:14)
Comment by Antonio Fernandez (silveste) - Friday, 22 January 2021, 17:07 GMT
In my case I solved the issue by changing the nodejs version.
I just realized I had installed the package node-lts-fermium (14.15.4-1) instead, now I am using nodejs (15.6.0-1) and all issues with apm and atom (unable to install packages) have been solved.