Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66745 - [apm] fails to search/install new packages

Attached to Project: Community Packages
Opened by Till (tillyboy) - Friday, 22 May 2020, 17:09 GMT
Last edited by freswa (frederik) - Saturday, 23 May 2020, 17:38 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Nicola Squartini (tensor5)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:
apm fails to search/install new packages. Error is reproducible after reinstalling apm/atom/npm and trying npm rebuild -g. Is fixed when installing atom-editor-bin from AUR. I have also noticed a lot of atom bugs lately, not sure if those are associated, but since this issue is explicitly about apm, I would say it isn't.

Additional info:
* working versions (AUR):
* atom: 1.47.0
* apm: 2.4.5
* broken versions (Community):
* atom: 1.46.0
* apm: 2.5.0-1
* reproduces these issues:
* https://github.com/atom/apm/issues/828
* https://github.com/atom/apm/issues/635

Steps to reproduce:
1. Install atom+apm (from the community repos)
2. Try to install any atom package.

Possibly related:
https://bugs.archlinux.org/task/65700
This task depends upon

Comment by Till (tillyboy) - Friday, 22 May 2020, 17:09 GMT
I am stupid, can I somehow edit the title?
Comment by Nicola Squartini (tensor5) - Wednesday, 10 June 2020, 01:01 GMT
Can you be more specific? Which package fails to install?
Comment by Till (tillyboy) - Wednesday, 10 June 2020, 20:33 GMT
Several, I tried atom-latex, linter, linter-spell and linter-spell-latex. All failed. As I said I currently run the AUR version. Did you try the Community build without error? Are your version of apm and atom the same as the ones specified above? Just checked with pacman, community is at 1.47 now, so the issue might have already been fixed.
Comment by Nicola Squartini (tensor5) - Thursday, 11 June 2020, 00:14 GMT
apm is now at version 2.5.0. Try that.
Comment by Ismael Bejarano (ismael) - Thursday, 11 June 2020, 16:58 GMT
It seems that an upgrade to node break a dependency of apm.

A fresh install of atom going to Edit/Preferences/Install create the attached trace.
Comment by Nicola Squartini (tensor5) - Friday, 12 June 2020, 00:38 GMT
Are you using nodejs-lts? Try nodejs 14.
Comment by Ismael Bejarano (ismael) - Friday, 12 June 2020, 04:16 GMT
Installing nodejs (14.3.0-1) fixed the problem of installing packages in atom.
Comment by Till (tillyboy) - Friday, 12 June 2020, 07:42 GMT
> Are you using nodejs-lts? Try nodejs 14.

Aha! Works for me as well. I didn't even know I was running the LTS version, ty for the hint.

Loading...