Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66707 - http://www.archlinux.org/check_network_status.txt returns 404

Attached to Project: Arch Linux
Opened by Eduardo Rocha (hockdudu) - Tuesday, 19 May 2020, 11:48 GMT
Last edited by Giancarlo Razzolini (grazzolini) - Tuesday, 19 May 2020, 12:41 GMT
Task Type Bug Report
Category Web Sites
Status Closed
Assigned To Jelle van der Waa (jelly)
Sven-Hendrik Haase (Svenstaro)
Giancarlo Razzolini (grazzolini)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
NetworkManager calls http://www.archlinux.org/check_network_status.txt for checking the connectivity. This page usually returned something like "NetworkManager is online" (as in https://pkgbuild.com/check_network_status.txt), but now it returns a 404 page.

The wiki page (https://wiki.archlinux.org/index.php/NetworkManager#Checking_connectivity) links a nginx-config file stating that no logs are saved in this URL. But if this config isn't being applied (as a 404 page is being returned), are the connections being logged on the server?

This doesn't affect NetworkManager's ability to detect whether the connection works or not.
This task depends upon

Closed by  Giancarlo Razzolini (grazzolini)
Tuesday, 19 May 2020, 12:41 GMT
Reason for closing:  Not a bug
Comment by Giancarlo Razzolini (grazzolini) - Tuesday, 19 May 2020, 12:41 GMT
If you access this over a browser, the sts preload will kick in and it will automatically change the request to https. If you do it via curl, the result is as expected:

$ curl http://www.archlinux.org/check_network_status.txt
NetworkManager is online

NetworkManager, as far as I know, only access the http url. Also, we use reduced logging on nginx:

https://gitlab.archlinux.org/archlinux/infrastructure/-/blob/master/roles/archweb/templates/nginx.d.conf.j2#L80

Loading...